I normally mount my windows share as follow:

mount -t cifs //192.xxx.x.xx/share -o username="username' password="pass" /mnt/mountPoint

now I am trying to mount my epson scanner which has a SD card that can be shared on the network.

I did the same command but it failed to mount. pinging the device is fine. My epson share doesn't have a username or password.

Can anyone suggest any command to try?

Recommended Answers

Your options for username and password are wrong. It should be:

mount -t cifs //192.xxx.x.xx/share /mnt/mountPoint -o username="username",password="pass"

Also you need to do that as root, or sudo. If your mount doesn't require authentication, then leave the username/password options out altogether.

Jump to Post

All 2 Replies

Your options for username and password are wrong. It should be:

mount -t cifs //192.xxx.x.xx/share /mnt/mountPoint -o username="username",password="pass"

Also you need to do that as root, or sudo. If your mount doesn't require authentication, then leave the username/password options out altogether.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.