Hi

I want to install stunnel in user mode.
By user mode I mean that I have created a user using adduser xyz.
Now when I run the ps -aef | grep stunnel .. it should show in xyz and not in root.
One school of thought was to use the parameters setuid and setgid in stunnel.conf by assigning them both "xyz".
but when I run the daemon, the errors flash
stunnel.pem: No such file or directory (2)
Service [https]: Failed to initialize SSL context

Please drop in ur views :)

Recommended Answers

What is the user.group ownership and flag settings on the stunnel.pem file and the directory it is in? It is likely that either the flags/ownership on the .pem file or the directory containing it are wrong.

Jump to Post

All 3 Replies

What is the user.group ownership and flag settings on the stunnel.pem file and the directory it is in? It is likely that either the flags/ownership on the .pem file or the directory containing it are wrong.

its done .. never mind :)

How do you resolved the issue?
I have your same issue and I can't find the correct way to generate the stunnel.pem file

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.