0

First of all I would like to thank CSCGAL for a very informative tutorial on setting up samba. As you may well have guessed I am a linux newbie. I went through the tutorial and executed all of the steps as described... but when I restarted samba and tested the access rights I found that Windows XP sees the directory but I'm never asked for a user ID or password. When I test it locally on the linux box using "smbclient //localhost/share" it will ask me for my password as expected and it lets me log in. I can browse through the directories but I can't create directories or files on either linux or WinXP. I get the following error message:

[scott@redhat1 ~]$ smbclient //localhost/share
Password:
Domain=[REDHAT1] OS=[Unix] Server=[Samba 3.0.22-1.fc5]
smb: \> mkdir fiddle
NT_STATUS_ACCESS_DENIED making remote directory \fiddle
smb: \>

I am running Samba 3.0.22-1 on a Fedora Core 5 installation on my home network. I have also attached my /etc/samba/smb.conf file. I also made sure to chmod 777 the /share directory to give it full permissions.

/etc/samba/smb.conf
==============
[global]
workgroup = mcintyres
server string = RedHat1 Samba Server
hosts allow = 192.168. 127.
log file = /var/log/samba/%m.log
max log size = 50
security = user
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

[share]
comment = share on RedHat1
path = /share
browseable = yes
writeable = yes
printable = no
public = yes
read only = no

Any help from this forum would be greatly appreciated.

2
Contributors
2
Replies
3
Views
11 Years
Discussion Span
Last Post by test
0

First of all I would like to thank CSCGAL for a very informative tutorial on setting up samba. As you may well have guessed I am a linux newbie. I went through the tutorial and executed all of the steps as described... but when I restarted samba and tested the access rights I found that Windows XP sees the directory but I'm never asked for a user ID or password. When I test it locally on the linux box using "smbclient //localhost/share" it will ask me for my password as expected and it lets me log in. I can browse through the directories but I can't create directories or files on either linux or WinXP. I get the following error message:

[scott@redhat1 ~]$ smbclient //localhost/share
Password:
Domain=[REDHAT1] OS=[Unix] Server=[Samba 3.0.22-1.fc5]
smb: \> mkdir fiddle
NT_STATUS_ACCESS_DENIED making remote directory \fiddle
smb: \>

I am running Samba 3.0.22-1 on a Fedora Core 5 installation on my home network. I have also attached my /etc/samba/smb.conf file. I also made sure to chmod 777 the /share directory to give it full permissions.

/etc/samba/smb.conf
==============
[global]
workgroup = mcintyres
server string = RedHat1 Samba Server
hosts allow = 192.168. 127.
log file = /var/log/samba/%m.log
max log size = 50
security = user
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

[share]
comment = share on RedHat1
path = /share
browseable = yes
writeable = yes
printable = no
public = yes
read only = no

Any help from this forum would be greatly appreciated.

By the way, I tried the same thing in SUSE Linux 10.0 and it worked fine. There must be something in Fedora Core 5 that's messed up. I'll research into it and let the forum know what I find.

0

By the way, I tried the same thing in SUSE Linux 10.0 and it worked fine. There must be something in Fedora Core 5 that's messed up. I'll research into it and let the forum know what I find.

I just figured this out myself 5 mins ago...it's been a problem for years, but not serious enough that I'd spent any time on it.

Start with share level access first, then work your way up to user level.
security = share
guest account = root

My problem was that I didn't define who the guest account was impersonating. Put in a
in your smb.conf and you'd be headed in the right direction (of course, use a different account once you get it working).

Basically, get your samba wide open, make sure it works, then start closing up the security.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.