0

Have tried but failed to setup Linux to share our PC's for home use.
Linux error "cannot find any workgroups in your local network" . Does not recognize Linux or windows users. I have used Yast to setup Samba but still no go.

What I am missing here. Any straight forward suggestions, instructions or links would be very helpful.

5
Contributors
6
Replies
7
Views
12 Years
Discussion Span
Last Post by abushman
0

Hello,

In order for samba to work properly, you need to have the following:

* Proper hardware setup (network cables, switch/hub)
* Proper protocol setup (ip number scheme)
* They should be part of the same workgroup
* The smb services started properly.
* Samba users mapped to Linux users.

You might have better configuration options using webmin as a configuration tool, or SWAT.

If you have more troubles, look on DW for a samba setup guide. I know there is one here... I am just not able to go dig for it at the moment.


Christian

0

Thanks for the reply.

Our PC's work fine in W2W (windows to windows / workgroup) settings - all files, printers, etc are shared. This has been the case for many years using XP/2000.

But in Linux, it is a no go. The Linux error is always the same "unable to recognize any workgroups in your local network". - will not recognize another Linux or PC station. However the Linux windows network icon is available in the local network setting but that as far as I get. As far as I can tell, Samba is installed.

I welcome any suggestions you may have. If I were setting up the PC's in a windows environment and experienced these issues, I probably would have uninstalled the network cards, change the settings and started over.

But with Linux I'm not sure where to begin short of reformatting the drives in the hope of correcting some serious conflicts or file corruptions.

Thanks again.

BCI

0

A stab in the dark...

I only really use Fedora and very occasionally Ubuntu.

When you first install Fedora, and then setup Samba you will not be able to connect to any Windows machines, and the Windows machines, will either not be able to connect to the Fedora machines OR the Windows machines just won't see the Fedora machines.

The problem is (in Fedora) that you need to trust your Network card in the Fedora machines so that they are allowed to communicate with your network.

I have only seen SuSE in the Live CD format, and I don't have one to hand so not sure if this is something similar in SuSE.

In Fedora you would click Applications, System Settings, Security

Towards the bottom of that window you would see an option for Trusted Devices in the case of Fedora you would need to tick which ever interface connects to you local network - normally eth0

Any devices that aren't ticked sit behind a firewall and will block the Samba requests.

As I don't know if there is anything similar in SuSE, this is just a stab in the dark, another option would be (as long as your on a network with a Firewall protecting your internet connection) to find the setting in SuSE to disable the firewall completely if you can't identify anyway of trusting your network devices.

Just a suggestion - might at least point you in the right direction.

Steveneven (Dave)

0

I'm new to Linux too, and I just installed SUSE 9.2 last night. it was not till this afternoon after much system searching that I found that it's the fire wall that is blocking the windows shares, I believe that by default (absent the firewall) SUSE will see your shares. using yast control center/system/runlevel editor, you can configure and/or disable the firewall. Since I know little about for now, I just disabled mine for now. Hope this helps.

0

I'm new to Linux too, and I just installed SUSE 9.2 last night. it was not till this afternoon after much system searching that I found that it's the fire wall that is blocking the windows shares, I believe that by default (absent the firewall) SUSE will see your shares. using yast control center/system/runlevel editor, you can configure and/or disable the firewall. Since I know little about for now, I just disabled mine for now. Hope this helps.

Glad to hear from a new SUSE 9.2 Linux user. Actually , I had tried your suggestion, but it is still a no go.

Unfortuantely, the support for SUSE 9.2 is very limited. The extent of the tech support is not much more than assisting a new user in how to open the box and insert the CD's for installation. Paid support is available at $39.00 for 20 minutes. Ouch !

Overall, I am more than impressed with the version. My hope is to eventaully use Suse for my small business as I see many advantages over Windows. So, I thought I would first give it a try at my home using the several PC's my kids use in a home network environment.

But not being able to get tech support is the challenge. Have you come accross any outside tech support services that charge at a resaonable fee ? As you can see from this tread, the responses have been limited.

If you have any new ideas since your reply, please let me know.

0

Hello:
If you still need help I could help. There are a number of things that you are trying to do. you want the pc to connect to linux and linux then back to a pc

to test a connect to a windows box just get the ip of the pc
and open a browser in linux like mozilla and type
example smb://192.168.0.108/utopia
note utopia is the name of my shared folder on the utopia pc
then
and add it to your /etc/hosts file on the linux box like this example
# IP-Address Full-Qualified-Hostname Short-Hostname
#
127.0.0.1 localhost
192.168.0.104 utopia
#utopia is my pc

once added to the /etec/hosts file you can browse with the linux network browsing. Linux is pretty smart to read windows windows can read linux or unix thats why the samba server is need next.
note just make sure your workgroup under yast samba client is listed there

1. first for a windows pc to connect to a linux box you need a samba server server running on the linux box.
2. you also need the user on the pc to be added to the smbusers file and the smbpasswd and unix users
a. add each pc user to a unix id on linux box
b. update samba stuff:
in a term window cd /etc/samba
example:
# cd /etc/samba
# ls
. .. dhcp.conf lmhosts secrets.tdb smb.conf smbfstab smbpasswd smbusers

C. vi and add all you Pc user ids to each of the files for example in
smbusers add
pc_id1 = pcguest
pc_id2 = pcguest

then copy the root password line from smbpasswd file
and add it below root's
example:
root:0:AD929F34BDA1857DC81667E9D738C5D
pc_id1:0:AD929F34BDA1857DC81667E9D738C5D
pc_id1:0:AD929F34BDA1857DC81667E9D738C5D
save file

login to a xterm as root
and execute for each pc_id added
smbpasswd pc_id
you will be asked for new samba passwords I would keep them the same a the unix passwords.

then launch KDE control panel go to
Internet and Network
then select samba configuration
set you pc work group
set security to share
make sure all unix users are added.

finally go to yast and launch the samba server (this is where you will actually start samba) make sure you workgroup is added and click finish
in a term window if you type ps -eaf | grep smb
you should see
this
linux:/etc/samba # ps -eaf | grep smb
root 8748 1 0 22:20 ? 00:00:00 /usr/sbin/smbd -D -s /etc/samba/smb.conf
root 8752 8748 0 22:20 ? 00:00:00 /usr/sbin/smbd -D -s /etc/samba/smb.conf

This shows the smb deamons running.

now try to access linux from pc it.

after al of this if you would like to discuss email me
durandal31@aol.com
send me your phone # I can call and discuss

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.