0

Hello All,

I am new to the forum and have a bit of a problem...

I am trying to change the windows generated UID numbers to specific UIDs when I log in to the linux machines.

I am having trouble changing the UIDs to specific numbers. I downloaded and installed SFU and changed the unix ids on the windows side but the ids aren't changing on the linux side when I log in. they are still the same windows generated UIDs. I attempted changing the winbind_idmap.tdb file which did let me change the UID on the local machine (which is fine) but when I log in as that user the UID will not resolve to the user name anymore (and i get weird errors).


I modified the winbindd_idmap.tdb file with no problems and got it to work when I did an

>"id username"

Command it would show the changed UID and GID.. The problem I am having now is that when I try to login as the modified user it cannot resolve a username to that UID. When I open a terminal it looks like this…

[I have no [EMAIL="name!@computer"]name!@computer[/EMAIL] directory]

Is there a file that maps UIDs to specific user names? I looked in the samba directory (where I found the winbindd_idmap.tdb file) and no other database files have username information in them.
Any ideas on that?

Any help would be great,

-Justin

4
Contributors
4
Replies
5
Views
10 Years
Discussion Span
Last Post by alienlinux
0

Typically, the passwd keeps the UID's of users, if your using winbind however, it will probably be controlled by the domain controller, if you do a getent passwd do you see the users and their UID's?

And did you restart the winbind daemon after making the changes?

0

I tried getent passwd and found my username being attached to the UID I configured in the winbindd_idmap.tdb file. And it looks fine. But I still have the same problem. It will not resolve the username. I get errors saying that a username cannot be found for my uid when I log in using my username.

Are there any other files that would have my username/UID information?

By reseting the domain controller you mean just restart the windows box right? I will do that but I don't think that will help. I also run a local samba service restart everytime I make a change.

0

not sure if i understand completely, but if your looking to change the UID of the *nix user, you use vipw :) do not use vi on passwd!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.