0

I have tried the instructions from Red Hat, the instructions from a guy on JustLinux.org and I cant get Samba to work. I downloaded the latest version of Samba and it installed ok. I can view shares on Linux from the Windows machines, but I cant write files in the shares.

Any ideas appreciated, thanks much.:mrgreen:

2
Contributors
3
Replies
4
Views
11 Years
Discussion Span
Last Post by DMR
0

* Can you start by posting the contents of your smb.conf file, please.
* Provide as many details as possible regarding what you have already tried, as that info might give us some clues.
* Have you created accounts on the Samba server for all of the users who will be accessing the share(s) from the network? Read the useradd and smbpasswd man pages for more on that.
* What exact errors or actions occur when you try to write to the Samba shares?
* Post the lines from your /etc/fstab file which relate to the partitions on which the shares reside.

->Resource linkage:
Although written for an earlier version of Samba, this online O'Reilly book is a very good reference to have bookmarked.

0

#======================= Global Settings =====================================
[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = MYGROUP

# server string is the equivalent of the NT Description field
server string = Samba Server2

; hosts allow = 192.168.1. 192.168.2. 127.

printcap name = /etc/printcap
load printers = yes

; printing = bsd

; guest account = pcguest

log file = /var/log/samba/log.smbd

max log size = 50

security = user
; password server = <NT-Server-Name>

; password level = 8
; username level = 8

; encrypt passwords = yes
; smb passwd file = /etc/samba/smbpasswd

; unix password sync = Yes
; passwd program = /usr/bin/passwd %u
; passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*

; username map = /etc/samba/smbusers

; include = /etc/samba/smb.conf.%m

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

; interfaces = 192.168.12.2/24 192.168.13.2/24

; remote browse sync = 192.168.3.25 192.168.5.255
; remote announce = 192.168.1.255 192.168.2.44

; local master = no

; os level = 33

; domain master = yes

; preferred master = yes

; domain logons = yes

; logon script = %m.bat
; logon script = %U.bat

; logon path = \\%L\Profiles\%U

; name resolve order = wins lmhosts bcast

; wins support = yes

; wins server = w.x.y.z

; wins proxy = yes

dns proxy = no

; preserve case = no
; short preserve case = no

; default case = lower

; case sensitive = no

#============================ Share Definitions ==============================
[homes]
comment = Home Directories
browseable = no
writable = yes

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = no
writable = no
printable = yes


[myshare]
comment = Root and Jon's stuff
path = /myshare
valid users = root jon
public = no
writable = yes
printable = no
create mask = 7777


The share named /myshare may be working, I dont know. I have used "smbpasswd" to set the password for samba users. I have put the user names in the "smbusers" file to map Linux to Samba user names. I tried configuring and adding users with SWAT without success, so this smb.conf file is fresh, I have not changed anything through SWAT.

0

* What exact error do you get when you try to write to the share from the Windows boxen?

* Open a DOS window, run each the following commands, and post the exact results returned by each command:
net view
net view name_of_the_Linux_computer
net use * \\
name_of_the_Linux_computer\myshare
(Note the asterisk in the last command; it is part of the command)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.