0

I just installed Opensuse 13.1 "successfully" last night. However each time I boot the system it gives me the error (warning?) message: 'No system tray detected on this system. Unable to start, exiting'. The system itself is usable in spite of this message.... So what could be the cause of this problem and how do I resolve it? Anyone out there encounter a similar message? How did you get around it?

Secondly, I downloaded the Non-OSS products iso CD for Opensuse 13.1 to go with the OSS DVD but the system can't seem to be able to use it despite adding it to the list of repositories! Why should it fail when the OSS DVD worked just fine but for the above hickup?

Finally, I have a Qualcomm Inc. HSDPA 3G USB modem dongle (model GIGA 360) which I would like to use for internet connection on my Linux box but have no (Linux) drivers for it. It works fine under Windows 7. Can someone please point me to a website with a working solution? sakis3g has not worked for me..... might be using it wrongly?!! It is able to switch the modem but can't perform any of the other functions .... Except Exit!

Help!!!! And thanx in advance.

NewbieChameleon

3
Contributors
7
Replies
36
Views
3 Years
Discussion Span
Last Post by sDJh
0

In regards to the mobile broadband, your only real option is to test drive the various distros. Not sure about OpenSuse since I have not tested that in a while but you would be ideally looking for an 'out of the box' solution as setting this up for noobs is quite challenging.

From experience Ubuntu variants seem extremely good at detecting mobile broadband automatically. So I would try Ubuntu on a live CD or live usb drive (using unetbootin.) As internet is the priority.

0

@iamthwee;
Thanx, I'll try your proposal re: mobile broadband later. For now I've gotten into the thick of the pppd's and the AT commands and it seems a pity to abandon ship now! I got the following info which I believe could be a starting point by issuing the command: dmesg | grep usb

Screen Shot 1:
[0.643419] usbcore: registered new interface driver usbhid
[0.643420] usbhid: USB HID core driver
[1.030058] usb 1-4: new high-speed USB device number 4 using ehci-pci
[1.147582] usb 1-4: New USB device found, idVendor=05c6, idProduct=0023
[1.147588] usb 1-4: New USB device strings: Mfr=3, Product=2, SerialNumber=4
[1.147593] usb 1-4: Product: Qualcomm CDMA Technologies MSM
[1.147597] usb 1-4: Manufacturer: Qualcomm, Incorporated
[1.147601] usb 1-4: SerialNumber: 000000000002

Screen Shot 2:
[9.246774] usb-storage 1-4:1.0: USB Mass Storage device detected
[9.252988] scsi4 : usb-storage 1-4:1.0
[9.253258] usbcore: registered new interface driver usb-storage
[9.264470] usbcore: registered new interface driver usbserial
[9.264486] usbcore: registered new interface driver usbserial_generic
[9.264497] usbserial: USB Serial support registered for generic
[9.286546] usbcore: registered new interface driver option
[9.286564] usbserial: USB Serial support registered for GSM modem (1-port)

Can the above log entries be used profitably in this instance? Thanx again.

NewbieChameleon

0

@iamthwee,
Thanx very much for the link... I've been trying out the instructions / suggestions (all week!) and I have achieved some limited success - Limited in the sense that I only managed to connect to the internet on Linux yesterday (once) and today (again once) but both times with so much trial & error that each time I made a connection, I didn't even know what I did right! However, today I was able to bring my openSuse 13.1 up-to-date using the online repos! Next step? I'll document every route I take trying to connect till I get it right every time, then I'll automate the connection procedure.

I'll give a final report on the forum when I'm done. Thanx!

NewbieChameleon

0

@All,
I'm back with negative reports on both issues (hplip: systemtray & 3g HSDPA USB modem from Qualcomm Technologies MSM).

I downloaded hplip-3.14.1-run and installed it as instructed. I uninstalled an earlier version (hplip-3.10) but at the end of the run, I got this:-

PRINTER SETUP

Please make sure your printer is connected and powered on at this time.

RE-STARTING HP_SYSTRAY

HP Linux Imaging and Printing System (ver. 3.14.1)
System Tray Status Service ver. 2.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

coker.mu@linux-jm54:~> /usr/lib/python2.7/site-packages/gtk-2.0/gtk/init.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
set_interactive(1)
error: No system tray detected on this system. Unable to start, exiting.
_______________________________________ _ _ _ _

Yes sir! Back to Square One! Anyone found a working package yet? By the way,I tried increasing the sleep time from 10 to 180 secs in systemtray.py but it only took longer (3 minutes!) to bring up the error meassage!

NewbieChameleon

USB Dongle (Modem) in next post!

0

@All,
After having lived with hplip problem since my last installation of hplip-3.14.1, I was forced to go back to hplip-3.13.10-4.2-i586 which I installed using Yast yesterday. I'm glad to report that the problem vanished after rebooting and has not re-surfaced during the many subsequent reboots. I'd advise other affected parties running openSuse 13.1 to try re-installing hplip using the openSuse online repos 13.1 and 13.1-Update.

NewbieChameleon

N.B.
USB dongle (Qualcomm GIGA 360 modem) still giving me a headache; - nothing to report yet but still cracking my head on it!

0

I'm glad to hear you solved your printer-problem.

The unsupported dongle hasn't got anything to do with opensuse. It's a missing linux-driver and every distro is affected by it.

I am afraid it won't work, but you can try to update your kernel. This is safe.
Add a new repository, either via Yast or via command line like so:

zypper ar http://download.opensuse.org/repositories/Kernel:/stable/standard/ "Kernel-Stable"

and then update the sytsem via

zypper up

or alternatively via Yast or Apper.
After a reboot, check you dongle. If it works, than please report here for others who suffer the same problem.

If it's not working, then mail the producer of your dongle and ask them to provide a proper linux driver.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.