4
Contributors
11
Replies
27
Views
3 Years
Discussion Span
Last Post by archie.herbias
0

Is the projector physically connected to the laptop before you boot your laptop? Or are you plugging it in after the laptop has booted?

I often plug my Linux laptop into a projector at work. The only times I've ever had problems is when I plug the projector in after my laptop has booted. And in these cases it's just a case of restarting the X server to get the projector to display output from my laptop.

From a logged-in session, to restart X; log out of the current session to go back to the log-in screen. Then select the 'restart X server' option in the shutdown menu. Once X has restarted and you see the log-in screen again; the projector should now be showing some output from your laptop. Then you can log in and do whatever you want need to do!

I find that if the projector is connected to the laptop and is turned on before the laptop is booted, the projector always works. But if the laptop was started before the projector is connected, it always becomes necessary to restart the X-server from the log-in screen.

I hope that is of some help!

0

I have also found that if you go into the System->Preferences->Display page, you can usually get it to find the new display device (projector) and set that to be the output device, or set the display to mirror the output on both the laptop and projector at the same time.

0

@JasonHippy: thanks for your suggestion .i will try that :) .i connected the projector after the laptop booted .

0

@rubberman: the projector is not detected in the display .it's only the built-in display that apppears :)

0

Ok. That has worked for me in the past. Sometimes it takes a few minutes for it to be detected, but then my last Ubuntu distribution that I used for any such purposes was 9.04. That one worked great with plug-in projectors - I used it to teach classes and give IEEE seminars without any issues at all. The newer versions of Ubuntu have the 3.x kernels and there may have been some regressions with regard to dynamic hardware detection.

Video driver issues may also be in effect here. If the internal chip set is nVidia and you are using the default nouveau driver, this can be a cause of the problem. If that is the case, then blacklist the nouveau driver and install the proprietary nVidia driver (download from the nVidia.com web site - not install from the Synaptic repository). That may work better for this.

Edited by rubberman

0

I agree that the most fool-proof method is to plug it in before starting to computer (or plugging it in and restarting). I imagine that a restart of the X server should work as well (there are a few ways to trigger a restart of X).

One thing that could throw a wrench in the works is if you are using a fixed Xorg configuration. This is not the default setup, as by default, the system is set to dynamically check display devices and choose a reasonable configuration (best resolution, duplicate screens, or something like that, depending on the specs of the displays). However, there is backward compatibility for this ancient way to set things up, which involves a Xorg configuration file that specifies exactly the display setup to use, and in that case, the X server would firmly choose to use that configuration, whether it makes sense or not. In modern times, this is almost never used (and there are also other more semi-fixed configurations, such as Xrandr that are more appropriate). And if you have set up such a manual configuration, you would remember it, because this is not like flipping a switch by accident. However, if you had some graphics driver issues and used some instructions from the web on how to solve it, you might have setup such a fixed configuration without knowing about it. If this is the case (check the xorg.conf file), then you might have to find a way to revert back to a dynamic method such as the default (no xorg.conf) or Xrandr.

The last time I plugged in a projector to a Linux laptop, it was running Kubuntu 13.04. Almost immediately after plugging in the projector, I got a pop-up window that gave a choice of display configurations (clone display, side-by-side, etc.) and then that was it. Everything was automatic.

There could be some dependence on your graphics card driver and your hardware (how old it is). Maybe the driver or hardware does not support the "hot" plugging of a new device, or maybe, not even multiple monitors (unlikely, but possible), have you ever had multiple monitors working on it? If the problem persists, you might want to check for your specific graphics hardware and driver for any known issue.

0

@mike: This is my graphics card driver: VESA: IntelĀ® Sandybridge/Ivybridge Graphics

i don't know if it's really the problem. I just bought my laptop last year on December. I have lenovo g400.

0

This is my graphics card driver: VESA: IntelĀ® Sandybridge/Ivybridge Graphics

That's great. Intel graphics cards are the best for Linux because Intel actively develop their own open-source drivers for their cards, and because they are open-source, they are included in Ubuntu by default. This means that not only are they up-to-date, but they are there by default and are backed by solid and active development. With Nvidia and ATI, the situation is quite a bit worse (but they are starting to catch on).

So, I would pretty much discount that as being the source of the problem, given that it's Intel and that it's very new.

Just try what has been suggested already.

Also, not all projectors are created equal. Some projectors are really annoying and simply don't work with all computers (even Windows / Mac computers).

0

i've tried connecting an external monitor and still it didn't recognized it. i really don't know what's the problem .do i need some configurations ? .like adding modes in xrandr ?

0
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1366 x 768, current 1368 x 768, maximum 1368 x 768
default connected primary 1368x768+0+0 0mm x 0mm
   1366x768        0.0  
   1368x768        0.0* 

this is the output when i run xrandr -q

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.