I just set up a samba media server and I got it up and running but it currently has to have a username and password to access the files. Do you know lines I need to edit in these two files to allow anyone, user or not to access the files, read only obviously?

garrett@bedroom /etc/samba $ cat smbshared.conf 
[Movies]
    comment = Linux Media Server
    path = /home/garrett/Videos
    browsable = yes
    guest ok = yes
    read only = yes
    available = yes
    public = no
    writable = no
    valid users = garrett

garrett@bedroom /etc/samba $ cat smb.conf
[global]
server string = Media Server
workgroup = workgroup
netbios name = bedroom
security = user
encrypt password = yes
guest account = nobody
name resolve order = bcast host
include = /etc/samba/smbshared.conf

If you have SELinux enabled then try this:

setsebool -P samba_export_all_ro on

I think that you need to remove "valid users = garrett" in smbshared.conf.