0

I have Kali Linux and a week or 2 ago I made a new user which was a copy of root. Now I am getting message that new updates are available and when I click install it asks me for administrative password. When I enter the user's password I get error password is wrong, if i enter Root's password it says user is not root to update the programs. How can I give permission to the user to be able to modify those files/install updates?

3
Contributors
8
Replies
24
Views
3 Years
Discussion Span
Last Post by Slavi
0

The problem is that your new user is not a "sudoer", which means a user that can run commands as super-user. To grant that user the right to run such commands, you have to add it to the "sudo" group. To do this, you must login as a sudoer account (e.g., as root, or as the original user account from which you could install updates and such). Go to a terminal, and write this command:

$ sudo adduser <username> sudo

where <username> is replaced by the name of the new user (note, you will have to enter your original user password). At that point, you should be able to run sudo with the new user, you can test that out by just logging in with that account and try as command like $ sudo echo "hello" and see if it succeeds.

There are also a few other ways to add a user to the list of sudoers, you can google for them if the above does not work.

0

Hey Mike, thanks for your response. My new user is a sudoer. I have installed a lot of software and changing desktop environment etc, setting date/time and everything required it to be a sudoer. If I run things from the terminal with sudo it asks for the user PW and then everything is fine. The updates are a graphical tool saying for example 60 updates are available

0

Hey Mike!
Yes this helped amazing!

Just to mention for future usage, you have to fix gksu-properties within the current user you want to have the permissions not from the root account (I did from root, didn't work so tried from not root account the permission wasn't changed so just changed it on it and works like a charm!)

1

By the way, if you want to install software updates through the command-line, you can do this:

$ sudo apt-get update
$ sudo apt-get upgrade

And if there are kernel updates, do this:

$ sudo apt-get dist-upgrade

Just wanted to point that out, in case you didn't know.

0

Anyone that knows about Linux Centos 6.5 Minimal? And can help me? Answer FAST! Plus you gonna receive money, for it!!! =)

0

Many people in here are skilled enough to help you out but instead create your own thread instead of stealing a solved one!

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.