0

Hello.
I posted this thread a few weeks ago on a different forum. But the tsunami of answers drowning :mrgreen: makes me think I was probably on the wrong forum... :o
Well, as a matter of fact I have installed Linux (SuSE 10.0). But I cannot setup my network. I've read various help documentations over the web and followed the instructions (with yast).
My network card is detected and I have Trendnet ADSL modem router with DHCP capability. But when I configure my network even with static IP, it does not seem to be received by the system. The IP remains at 127.0....
The result is: No networkking, and no Internet. :cry:
I have a brand new Dell computer with a built in Dell network card. I have tried both 32 bits and 64 bits (upon suggestion by SuSE itself) and no joy. More info about my rig in my profile.

Thanks 4 help.


2
Contributors
1
Reply
2
Views
11 Years
Discussion Span
Last Post by DMR
0

* What is the exact model/chipset of the NIC?
* What driver module are you using?
* Your rig's description says that your are running Fedora on that box as well; what stats/info does Fedors tell you about the NIC and driver?

Log in as root and open a terminal window.
* Use one of the following commands to verify that your card is at least basically identifying itself to the system:
lspci -vv |less
less /proc/pci
cat /proc/pci

In the resulting output, look for the "Ethernet Controller" entry. It should contain information about your model of card and/or its chipset, as well as IRQ, I/O port, and memory address values.

* Run the ifconfig command; information concerning your NIC should appear in the resulting output. You should also see stats for the loopback (lo) device 127.0.0.1. If you've already tried to enter your IP info (inet addr, Bcast, Mask) through a GUI network configuration utility, verify that those values are correctly reflected in ifconfig's output. Also check for RX/TX errors and collisions. If eth0 is not listed when you run ifconfig, try "ifconfig -a"; the "-a" option forces ifconfig to report all network interfaces, active or not. If eth0 appears only when you run ifconfig with the -a option, it is definitely not correctly configured.

* Verify that the correct module is being loaded for your ethernet card by issuing the "lsmod" command; you should see the module name in the resulting list of loaded modules. If not, issue the following two commands and try again:

depmod -ae
modprobe <name of your NIC's module>

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.