0

I have Skype installed on my PC, as i knew using port 80 as default. Then, i changed httpd.config to 8080, but my apache not starting
After did a little googling, i have to uncheck 443 on Skype setting. My question: is the apache uses 2 ports? And why?

Edited by pritaeas: Moved to *nix.

2
Contributors
2
Replies
26
Views
3 Years
Discussion Span
Last Post by old_apache
1

It's so your server can serve pages over http and https/ssl.

Port 80 is the default port for http traffic (in your case, you've redirected http to port 8080 on your server, which is fair enough). And port 443 is the default port for https.

Typically on a dedicated web server, you wouldn't have Skype installed. So normally this isn't an issue. But your server must be running on a desktop or laptop PC that you use for general day to day usage.

To stop the problem, you have disabled the use of port 443 in skype.
The other option would be to use a different port for https on your server (442?), just like you did with port 8080 for http.

If ssl/https is not required, I imagine it should also be possible to disable it. That said, I haven't done any serious web development for a number of years, so I've had no need for a server. Consequently, I haven't really messed around with setting up and running an Apache web-server for a looong time. So I can't really offer any detailed info. But I'm sure that someone else here will be able to help!

0

I should have realized that 443 for ssl
I just changed port 443 to 442 on http-ssl.conf file
anyway, thank you

Edited by old_apache

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.