0

I was using the Linux Mint Flawless media server to host all my movie rips as .mkv files but I decided to go with a standard no GUI Debian server instead. I set up an NFS server to host my files with the most likely client to be my Western Digital TV Live streamer which is what I've always used to stream my movies from my computer to my TV. When I select a shared Linux server from my WD TV Live device it sees my NFS server and it displays the shared directory, but after selecting the directory I get this error. -> There is no media available for playback. This has always worked in the past on my Mint server through Samba but now it can't see any media on my Debian server using NFS. I really don't want to go back to Samba and I would prefer a standard bare bones server to the fancy Mint FLAWLESS server.

Here is a copy of my /etc/exports file

# /etc/exports: the access control list for filesystems which may be exported
#       to NFS clients.  See exports(5).
#
# Example for NFSv2 and NFSv3:
# /srv/homes       hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_subtree_check)
#
# Example for NFSv4:
# /srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)
# /srv/nfs4/homes  gss/krb5i(rw,sync,no_subtree_check)
#
/home/garrett/Videos *(rw,sync,subtree_check)

Any ideas?

1
Contributor
1
Reply
15
Views
2 Years
Discussion Span
Last Post by lewashby
0

Well I sorta solved the problem. I was keeping my movies in /home/garrett/Videos/Movies and I had my NFS server set to share /home/garrett/Videos/ I wanted to do it that way hoping that I could then add other libraries like 'Shows under the Videos directory. For whatever reason that doesn't work and I have to specify exactly what directory to share because it doesn't share sub directories.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.