I just got a mepis live cd... I am running it live on my laptop.

I was able to get sound installed, but i am having trouble installing a program. The program is called "Wireless Assistant" (http://sourceforge.net/projects/wlassistant/)

Mepis detects my wireless, and it will allow me to detect my two access points, but i can not connect (dont know how...)

This is what i was told to do to install it;

tar -xjvf wlassistant-0.3.9.tar.bz2
cd wlassistant-0.3.9
./configure --prefix=/usr 
make
su -c "make install"

I am able to extract it, and i am able to change the directory... but i can not run the command "./configure --prefix = /usr". It isn't recognised as a command?


Sorry for such a newb question, but i am still used to windo$...

Can someone please help me? I am apart of another forum, and i get extremely mad when people ask dumb questions like this, but i really have no idea! :confused:

Thank you! (i just want wireless!)

./configure is actually telling the computer to run a shell script that is contained in the current directory (which you just set by using cd ). If the terminal cannot find the command, perhaps you had better check to make sure it's there. Type the following at the prompt:

# cd wlassistant-0.3.9
# ls

Look at the output printed. There should be a file listed there named "configure". If the files don't seem remotely like the source code (no INSTALL, README files), then perhaps you're in the wrong directory.

If you're using a terminal app to enter your commands, usually the easiest way to solve the problem mentioned is to drag the wlassistant onto the terminal app, which will automatically paste the folder's location; add "cd" in front of it, and then hit return. Then try the configure script again.

Hope this helps

Yes, there is a file named "configure"...


Edit:

When i type in

./configure

i get the following error

bash: ./configure: /bin/sh: bad interpreter: Permission denied

What the heck???

That means that the shell can find the configure script, but cannot get past a certain line. This could be due to a number of things, but the easiest way to find out what's wrong is to try this command instead:

sh ./configure

Post any error messages you get.

Checking for Python        : /usr/bin/python
Checking for SCons        : [B]not found, will use mini distribution.[/B]
./configure: ./scons: /usr/bin/env: bad interpreter: Permission denied

Thank you for your help so far.

You may want to try downloading and installing SCons first to see if that fixes anything.

My other suspicion is that python is not in the PATH variable. Try running echo $PATH at the shell. You'll get a list of paths seperated by colons. If /usr/bin isn't listed, then you'll need to enter the following:

# PATH=$PATH:/usr/bin

And then try running the configure script again.

Sorry i am so dumb with linux... now how do you install SCons? :D

So i should try everything i tried before? Great... :)


Wait... I can't... tar.gz isn't a tar.bz2, so i can not do what i tried before... So, back to my sub-original question; how do i install it?

Ah. Unarchiving tar.gz is nearly identical to unarchiving tar.bz2. Just enter something like this at the shell:

# tar xfz scons-source-...

A directory containing the source code will then be created. cd to this, and then proceed with regular compilation steps.

Yeah, i figured that out after some experimenting.

I ran the setup instructions included in the readme, and it said to run

# python setup.py install

So i did, and it worked, but it came up with the error:

error: could not create '/usr/lib/scons-0.96.94': Read-only file system

Would this have anything to do with the fact that i am running it live on CD? Would it work better if i actually had it installed?


I am going to call it a day. I will play more tomorrow...

Would this have anything to do with the fact that i am running it live on CD? Would it work better if i actually had it installed?

No kidding...

I assumed that you had actually installed MEPIS from the LiveCD. No wonder. Yes, if you're interested in Linux, you should really try installing it. LiveCDs are a fun way to try out Linux, but the real fun comes once you've got a working install. Then you can actually install and compile stuff properly.

Umm. ok.... I got Mepis installed on my laptop...


SCons installed fine, (oh, why did i install that anyways? What does it do?)


But that wlassistant STILL doesn't want to install!

It keeps saying "bad interpreter: Permission Denied"!!!!!!!!!!!

SCons installed fine, (oh, why did i install that anyways? What does it do?)

You need it because Wireless Assistant was built with it, and so you need it to reconstruct the program when compiling.

But that wlassistant STILL doesn't want to install!

It keeps saying "bad interpreter: Permission Denied"!!!!!!!!!!!

The real question is to try the configure command again with the sh to find out what's actually going on. Make sure that this line here changes:

Checking for SCons        : [B]not found, will use mini distribution.[/B]

I don't think i was too clear...

SCons DID install fine... that was where the

Checking for SCons        : [B]not found, will use mini distribution.[/B]

came from


Now when i try to run the

tar -xjvf wlassistant-0.3.9.tar.bz2
cd wlassistant-0.3.9
./configure --prefix=/usr 
make
su -c "make install"

it still comes up with the

bash: ./configure: /bin/sh: bad interpreter: Permission denied

error!

I just want to get connected to the internet! Like i said before, i am able to "iwlist eth1 scan", and it will show both of my access points, but i dont know how to connect to one of them! How do you do that?

You don't need wlassistant to connect to the internet. iwconfig is a command-line utility (related it iwlist) that allows you to connect to access points, and is installed by default in nearly every Linux distro. First of all, run iwconfig to find out your wireless adapter:

# iwconfig

It will spit out various network adapters. The one that has wireless extensions is the one you want to take note of. Then use this for your connection like this:

# iwconfig ath0 essid "accesspoint"

Of course, you have to know the name of the access point to be able to connect to it. Then run iwconfig again to make sure it connected:

# iwconfig ath0

If the information printed out looks correct, proceed by getting your IP address either by static or DHCP

(for dhcp) dhcpcd ath0
(for static) ifconfig ath0 192.168.0.1
Comments
good advice

Aaah!!!!!!!!

It pains me to say this, but DHCP isn't installed.... (screaming uncontrollably)

I was able to connect up, but i still can't get on the net!

I have two choices here;
1) Install DHCP (i have no idea what to look for, so what should i google to find where to download it?)
2) Figure out how to assign an ip address... (i know how to do it, but how do i figure out what ip to use? My ISP bans static ips, but it shouldnt matter because of the router, right?

Ok. Something is SERIOUSLY wrong.

I download DHCP, and extracted it, but when i try to run the freaking

./configure

It comes up with the same fking error as it did with the wireless manager (which by the way i knew that i didn't need it, but i though that it would make linux a bit more user friendly... pff, what good that did me... :rolleyes:

bash: ./configure: /bin/sh: bad interpreter: Permission denied

There's quite a number of things which can be causing this. For one thing, this error occurs everytime if your hard drive is mounted with the noexec option. To fix this, you'd need to go into your /etc/fstab file, edit it, and make sure that when it lists your hard drive, no "noexec" line is present. If there is, remove it.

Secondly, it could be due to the configure script being in the wrong encoding format. Any script using DOS end-of-line symbols will totally mess up the script interpreter for Linux. Try editing the file and make sure there's no whitespace between #/bin/sh and the top of the file. Resave it.

Thirdly, try running the script again with sh. That is,

sh ./configure

And post the error results.

edit:

And yes you are right, you could assign your computer a static IP address, because it's from your router to your computer; the dynamic IP address is from your ISP to your router. To assign, simply use ifconfig, but be warned: many routers don't like static IPs either and prefer to assign them to you.

He he, i was trying to run it from my jump drive.... :D

oops... Well, that solves one problem... :)

He he, i was trying to run it from my jump drive.... :D

oops... Well, that solves one problem... :)

Yes, the funny thing about Linux is that although there's quite often scary error messages, the solutions tend to be rather simple. It happens to the best of us. :)

Well now... DHCP still doesn't work. I ran the ./configure, make, and make install, but "DHCPCD" still isn't a valad command...

(in a really whiney voice) I really just want to get on the net... :s

Well now... DHCP still doesn't work. I ran the ./configure, make, and make install, but "DHCPCD" still isn't a valad command...

(in a really whiney voice) I really just want to get on the net... :s

Congratulations! If it compiled and installed with no errors, you've already won the battle. Now all you need to do is find the command. :cheesy:

Usually the easiest way is to gain root, as root paths are generally set to the location of administrative tools like dhcpcd. So try something like:

# su
[enter password]
# dhcpcd ath0

If that doesn't work, you can try various paths such as /sbin/dhcpcd, /usr/sbin/dhcpcd, etc., or you can use the find command:

# find / -name dhcpcd | more

But congrats again on getting it compiled; that's always the biggest hurdle. ;)

under /sbin there are only commands called "dhclient, dhclient3 dhclient-script"

There is something called "DHCPD" under
/usr/sbin... When i try to do "DHCPD eth1", i get a bunch of text that bables on about websites and what not, but an error is show;

Can't open /etc/dhcpd.conf: No such file or directory

It is 12:30 in the morning here, so i am going to get some shut eye, and then see what i can do tomorrow.

Thanks for helping me so far! I kinda like linux, but it is soo user un friendly...

i think its maybe just mepis

i got the newest ubuntu and it connected to my encrypted wireless network no problems.

under /sbin there are only commands called "dhclient, dhclient3 dhclient-script"

There is something called "DHCPD" under
/usr/sbin... When i try to do "DHCPD eth1", i get a bunch of text that bables on about websites and what not, but an error is show;

Can't open /etc/dhcpd.conf: No such file or directory

Heh, that's because you're trying to run dhcpd which is not the same as dhcp[B]c[/B]d . Are you sure you downloaded the right package? dhcpd is the server daemon for DHCP, whereas dhcpcd is the client daemon for DHCP.

If you did download and install dhcpcd, keep searching. What does find / -name "dhcpcd" turn up?

downloaded the right package?

well now! That possibly solved another problem! :) Once again, i apologise for my lack of knowing linux, and networking. :p otherwise, i don't mean to brag, but i am pretty good with computers...

I will install the one at the link you provided.

How would i unintall the program in installed by mistake?

Ok, it installed. Now i get an

Error, eth1: timed out

Now what the heck am i doing wrong?

Great...

Now mepis locks on boot. :(

here is where it locks:

* Loading hardware drivers...                 [ ok ]
[17179583.340000] **** SET: Misaligned resource pointer: ddd1c202 Type 07 Len 0
[17179583.340000] ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 5
[17179583.340000] PCI: setting IRQ 5 as level-triggered

Ok, it installed. Now i get an

Error, eth1: timed out

Now what the heck am i doing wrong?

First of all, you may want to try simply connecting to the Internet. For some strange reason, I get this error whenever I use dhcpcd to get an IP address, yet it always seems to get an IP address.

Next, check with iwconfig to make sure that you're still connected to the access point:

iwconfig eth1

And make sure the info looks correct.

You can also check the IP address with ifconfig:

ifconfig eth1

If this still doesn't work, you can also manually set your IP address with ifconfig like I described before:

ifconfig eth1 192.168.0.1
* Loading hardware drivers...                 [ ok ]
[17179583.340000] **** SET: Misaligned resource pointer: ddd1c202 Type 07 Len 0
[17179583.340000] ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 5
[17179583.340000] PCI: setting IRQ 5 as level-triggered

This is an ACPI bug which you are experiencing. You *could* try to repair it in rescue mode, but probably the easiest thing is to disable ACPI. In GRUB (or whatever Linux bootloader you're using), look at the line that's similar to this:

kernel (hd0,0)/boot/vmlinuz root=/dev/hda1 PROFILE=dhcp

Now all you need to do is add NOACPI to the end of this.

This is only temporary of course, and if this works, you'll want to set it permenantly by editing the grub.conf file (usually located in /boot/grub or something similar).

This article has been dead for over six months. Start a new discussion instead.