0

I am new to linux and I just installed ubuntu on my hp dv6000t laptop. I try to download the nvidia-glx but when I try to install it with the command "sudo nvidia-glx-config enable" command it returns the following:

Error: unable to load nvidia kernel driver! Be sure to have installed
the nvidia driver for your running kernel.

I checked to see if i had the right kernel but i did. Can someone help me?

2
Contributors
5
Replies
6
Views
10 Years
Discussion Span
Last Post by John A
0

Did you try googling it?

First hit:
http://home.comcast.net/~andrex/Debian-nVidia/installation.html

The nVidia driver consists of two parts: a kernel module, and a collection of user-space libraries. The libraries [are] packaged for Debian in the nvidia-glx package. The kernel module is distributed in source form and packaged for Debian in the nvidia-kernel-source and nvidia-kernel-common packages.

Basically you've got the libraries, but lack the kernel module, which is eventually loaded up after the kernel is booted. I suggest following the guide, because it describes everything in great detail, and Ubuntu is based off of Debian, so the instructions will work.

0

I checked my packages under synaptic and It says that I already have the
"nvidia-kernel-common." Does this mean I do not need to build another kernel?

0

Follow the instructions. I repeat, follow the instructions.

First of all the article recommends finding out if you've got a stock or a custom kernel. Do that, although I'm nearly 100% sure that you've got a stock kernel.

Then it tells you to find out which distro to choose from ("testing" or "unstable"). Find it out, and set the variables.

Thirdly I recommend you use module-assistant to build your modules. It's explained very well if you click on the link to uncollapse the text under "module assistant".

So why didn't I answer your question? Because you didn't follow the instructions. It's actually explained very well, and basically using apt-get to grab nvidia-kernel-common package simply isn't enough. So that's what the article is there for. Follow it exactly, and it will work. You don't need to rebuild the kernel, because the only thing that's missing is the kernel module.

0

Thanks. I followed the instruction exactly and It worked!

If you follow instructions exactly, they tend to work. :cheesy: (At least that's how they're SUPPOSED to work.)

You may also want to mark this thread as solved by clicking the "mark as solved" button at the top of this thread.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.