0

Wow this is a bit weird. Well I'm not an expert in Linux. But I know that iptables responsible for the system firewall. So i went in to /etc/sysconfig and vim the iptables and i see that port 25 and 110 is accept. How come when I telnet the port 25 and 110, it is show that the connection is refuse. I did open up my router firewall also for the port 25 and 110. So I'm stuck at this point. Don't know why these two ports is not open. I need these two ports for my sendmail to be able to send and receive email to the outside source. Please lighten up me with your solution, anyone? :)

I'm really appreciated if you can, and I also really appreciated if you try. Thanks guy...

4
Contributors
6
Replies
7
Views
14 Years
Discussion Span
Last Post by John A
0

I'm a bit confused when you say you are trying to telnet into ports 25 and 110. Do you mean you're trying to ping your server? You'll need to do a portscan to see if those ports are open or not.

Telnet is the daemon that lets you run a shell remotely, and is usually done via port 23.

0

I did try to do nmap -sS for localhost and etc.. 25 and 110 is in the state closed. But my router configuration is open for it.. and iptables' port 25 and 110 is accepting. When i do telnet.. (usually you telnet a port is to see if the port is accept the connection or not.. so you'll know it's open or closed).. for 25 and 110, it say connection refuse, but i telnet port 22.. and port 22 is open for a connection.

So any suggestion?

Thanks for replying to me so fast :)...

0

This isn't exactly my field of expertise. However, does it make sense that perhaps despite the ports being open through your firewall, sendmail is not configured properly, and therefore there is no daemon listening to those open ports, to respond to you when you try to telnet to them?

0

Yes, it sort of make sense. But I did run a check on my sendmail status, and it's up and running. About sendmail configuration is default from beginning, I didn't change anything, but only two line of codes. What I did was comment out the following line:

DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl

That is, place a dnl in front so it looks like the following:

dnl DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl

Then I remake sendmail.cf file by moving into the /etc/mail directory and typing in make -C /etc/mail

Then I restart sendmail. (/etc/init.d/sendmail/restart)

I think this is the right way to configure the sendmail so far. If you know what I did wrong, please let me know thanks.

So far, I'm clueless because my sendmail is not working the way it suppose to work, and the port 25 and 110 look like it was closed when I do the nmap, but I did check the iptables and see it was open, and my router also open those 2 ports.

:).. Thanks for trying to help.

0

There are other setting to consider. I've not used sendmail, but with postfix, there are a few things in the config file (/etc/postfix/main.cf in Fedora) that need to be unblocked:

mydomain = cs.ukzn.ac.za
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, $mydomain

This is of course a late reply (years late!) but I was searching for stuff on iptables and maybe this postfix info could help someone one day :)

Often if one thing doesn't work, something else is worth a shot :D

0

There are other setting to consider. I've not used sendmail, but with postfix, there are a few things in the config file (/etc/postfix/main.cf in Fedora) that need to be unblocked:

mydomain = cs.ukzn.ac.za
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, $mydomain

This is of course a late reply (years late!) but I was searching for stuff on iptables and maybe this postfix info could help someone one day :)

Often if one thing doesn't work, something else is worth a shot :D

You do realize that you're reviving a thread that is FOUR YEARS old, yes?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.