0

as the root user, when you shell configure xfree86 on freebsd with xf86config, after I'm done I save the config file to the default location. then when I try to start it with startx, it gives me this message. Am i saving the config file to the wrong location? I'm running this in microsoft virtualpc 2004, where it says video cards are not recognized as native devices... so i'm not sure if that is the source of my problem or not.

Build Operating System: FreeBSD 5.2 i386 [ELF]
Build Date: 07 December 2003
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Feb 4 12:13:42 2004
(==) Using config file: "/root/XF86Config"
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.

X connection to :0.0 broken (explicit kill or server shutdown).
xauth: creating new authority file /root/.Xauthority
xauth: (argv):1: bad display name ":0" in "remove" command
xauth: (argv):1: bad display name ":0" in "remove" command

3
Contributors
10
Replies
13
Views
13 Years
Discussion Span
Last Post by WEATHER CHANNEL
0

You have to configureX properly. I would suggest before installing any of the BDS's or Unix flavors to get a proper read out of hadware using aida32
from www.webattack.com

then install the correct port.....................I'll be back in 1 hour.

0

Ok I think I know the problem. There seems to be 2 methods to configure X. the commands are as follows as the root user: sysinstall--->Config--->XFree86-->xf86cfg(fully graphical) or xf86config(shell-script based)

I used both methods just to see where it was saving the new config file.

With the xf86cfg method, here is where it stores the updated config file:

XF86Config write configuration: /usr/X11R6/lib/X11/XF86Config XKB Write configuration: /usr/X11R6/lib/X11/X0-config.keyboard

With the xf86config method:

write: /etc/X11/XF86Config

[in both configuration methods I choose modest resolutions, 16 bit color, driver 'nv', and in the fully graphical tool I chose my geforce 4 ti4200 from a drop down list, in the shell config tool I choose 'GeForce' chipset]


NOW after I configured Xfree86 and KDE, this is the error message I get when I use 'startx', notice the line that says which config file X is attempting to use. It's the root config file, not the one I've been updating in the configuration routine. So all I have to do is figure out how to make X look at the correct config file right?

Build Operating System: FreeBSD 5.2 i386 [ELF]
Build Date: 07 December 2003
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Feb 5 16:09:21 2004
(==) Using config file: "/root/XF86Config"
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not ju the last messages.
This can be found in the log fe "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.

X connection to :0.0 broken (explicit kill or server shutdown).
xauth: creating new authority file /root/.Xauthority
xauth: (argv):1: bad display name ":0" in "remove" command
xauth: (argv):1: bad display name ":0" in "remove" command

0

First,did one install the xf86 packages?

# pkg_add -r XFree86

or

pkg_add -r [insert name of port]

Ok,during install what session did you choose to start with? It should have been the last prompt during install.
Say you choose a KDE session and you put in

startx
startkde

& the output was a error then you need to install some ports.

pkg_add -r kde

Say you did configuredX properly. Using EXAMPLE: [root@Thermalscripts] /root#

XFree86 -configure

or

xf86 config

then one followed the directions that it printed out on the screen. & when one went to save, the output it gave you was an error. That usally means you didn't configureX properly. (it wants to know the exact everything including the monitor hertz.)


Check to make sure you have KDE

pkg_add -r kde

Do you have ports installed?

You know most people have to install it a couple of times. I know my first time I kept booting up in a default GUI.But after your second or third time xf86 config goes quick and the whole install process only takes about 15 min. In my opinion I would say start over and write the config #'s/choices down. And make install ALL pkgs

/choose a familar gui for default.
I will keep a eye on the thread tonight. Hope I helped.


http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-install.html
http://www.vmunix.com/fbsd-book/book.phtml#ch-15

0

Ok I think I know the problem. There seems to be 2 methods to configure X. the commands are as follows as the root user: sysinstall--->Config--->XFree86-->xf86cfg(fully graphical) or xf86config(shell-script based)

I used both methods just to see where it was saving the new config file.

With the xf86cfg method, here is where it stores the updated config file:

XF86Config write configuration: /usr/X11R6/lib/X11/XF86Config XKB Write configuration: /usr/X11R6/lib/X11/X0-config.keyboard

With the xf86config method:

write: /etc/X11/XF86Config

[in both configuration methods I choose modest resolutions, 16 bit color, driver 'nv', and in the fully graphical tool I chose my geforce 4 ti4200 from a drop down list, in the shell config tool I choose 'GeForce' chipset]


NOW after I configured Xfree86 and KDE, this is the error message I get when I use 'startx', notice the line that says which config file X is attempting to use. It's the root config file, not the one I've been updating in the configuration routine. So all I have to do is figure out how to make X look at the correct config file right?

Build Operating System: FreeBSD 5.2 i386 [ELF]
Build Date: 07 December 2003
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Feb 5 16:09:21 2004
(==) Using config file: "/root/XF86Config"
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not ju the last messages.
This can be found in the log fe "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.

X connection to :0.0 broken (explicit kill or server shutdown).
xauth: creating new authority file /root/.Xauthority
xauth: (argv):1: bad display name ":0" in "remove" command
xauth: (argv):1: bad display name ":0" in "remove" command


----------------------------------------------------------------------
I also tried copying the XF86Config I create from /usr/X11R6/lib/X11/ to the /root. However when I 'startx', it still seems to be using the generic template file, not the properly configured file. This is the contents of /usr/X11R6/lib/X11/ directory, would any of them tell me what's going wrong? They seem to be very long files, so im not sure I could copy and paste them.:


# ls
Cards XF86Setup fonts rstart xkb
Options XKeysymDB fs twm xman.help
XErrorDB Xcms.txt icons x11perfcomp xserver
XF86Config app-defaults lbxproxy xanim xsm
XF86Config.98 config locale xdm
XF86Config.eg doc proxymngr xedit

0

what output are you refering to? when i configure X, it saves to the locations i specified in my last post.

when i try to startx, it gives me the error message i pasted on my last post.

0

X connection to :0.0 broken (explicit kill or server shutdown).
xauth: creating new authority file /root/.Xauthority
xauth: (argv):1: bad display name ":0" in "remove" command
xauth: (argv):1: bad display name ":0" in "remove" command
-------------------------------------------------------------------------


Ok,X doesn't have a valid config file. Have you done the following?

# /usr/X11R6/bin/xf86config
- run the X configuration utility

# vi /etc/X11/XF86Config
- ensure your configuration looks okay

& make sure you have KDE through the port server.
I'll be on tonight maybe but try that out. If you think it is a bug or if you just want instant help, sign up to the BSD [email="m@iling"]m@iling[/email] list.

0

Lol this is how I got it to work.


# /usr/X11R6/bin/xf86config
- run the X configuration utility

it wrote the new config file using an S3 video adapter to this location: /etc/X11/XF86Config


Then I copied that config file to /root and startx worked. It started right into KDE which I had previously set as the default. I think it was me choosing S3 instead of nvidia Geforce4 that made it work. I will mess around with it to make sure its working ok, but looks like it was the virtual environment that messed things up.

0

If you store the config file for X (XF86Config) in root's $HOME, then only root will be able to read that config, and if you try to launch X as a different user, that user will be reading the other (bad) XF86Config file.

To fix this, locate the other XF86Config file (usually /usr/X11R6/lib/X11/XF86Config) and rename it to XF86Config.old :

root@host# cd /usr/X11R6/lib/X11
root@host# cp XF86Config XF86Config.old

Then copy root's XF86Config to the same location and make it world readable:

root@host# cp ~/XF86Config /usr/X11R6/lib/X11/
 root@host# chmod +r /usr/X11R6/lib/X11/XF86Config

Also, ~/.xinitrc is the file that determine which window manager you will use when starting X. On Slackware, if you use xwmconfig, it will give you a text menu to choose your window manager. In FreeBSD, you have to manually create the file and edit it for your preferred wm.

Example:

user@host$ cd
 user@host$ echo startkde > .xinitrc
0

Lol this is how I got it to work.

# /usr/X11R6/bin/xf86config
- run the X configuration utility

it wrote the new config file using an S3 video adapter to this location: /etc/X11/XF86Config

Then I copied that config file to /root and startx worked. It started right into KDE which I had previously set as the default. I think it was me choosing S3 instead of nvidia Geforce4 that made it work. I will mess around with it to make sure its working ok, but looks like it was the virtual environment that messed things up.

Ok, so it worked. Here are some sites I use
http://www.freshports.org/

http://www.freebsd.org/gallery/gallery.html (let them know what your working with)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.