i have a mac G4 with OS X 10.2 (jaguar) and a couple of days ago i went to go on the comp and my brother had it in OS 9 but it had been sitting there unused for a while and began to index the computer. When i went on it i tried to change the startup disk to OSX and it asked me if i wanted to stop indexing and i said yes.....a screen then poped up that said stopping indexing...and remained like that for the rest of the day untill it froze. Frustrated i turned off the computer and when i turned it back on it won't start up properly. A picture of a file folder shows up and flashes between a question mark and the OS 9 logo. I have tried restarting it a number of times pressing "x", "option", and "shift" during start up ...and there has been no change. I have put in my OSX installation CD and done a disk repair on disk utilities and there has been no change. I have tryed resetting PRAM but i'm not sure if it has worked. If i have the installation CD in when restarting it always goes to the installation start screen no matter what i press on the keyboard during startup....... i'm not really sure what else i can do....i really don't want to lose info...but if i can get my computer to recognize my harddrive...i'd be happy with that

i ended up having to reinstall, i guess my comp couldn't identify or deleated some of the system folders it needed to run. Although everything turnd out ok...nothing was lost..YAY!

Don’t quote me on this, and I am not saying you should try it either,
but, when this happened to me, I took the drastic measure of
unplugging the power during the failing start-up, and I got my Mac
back with a "Your computer did not close down properly" message,
and then all was well.

But I did not say that!

Anyway, none of the info was missing, and I doubt that any
yours will be when you finally get in, which I'm sure you or
your local "Mac doctor' (best bet) will.


You got lucky. As nice as Macs are, they still are computers, and will lose data if you do the wrong thing. Backing up data to removable media (CD-ROM, DVD, network) is the only true insurance you have against hard drive failure.

I am surprised the indexing service corrupted your hard drive. Maybe it stumbled onto a permissions issue, maybe it did something else. The smart thing you did was NOT format the volume... you would have lost your information for sure.

Glad all is better for you. Now please go make some backups, so that you are at peace if it happens again. And be sure to refresh those backups as you need to.