OK so a while back I posted how a customer forgot her password and so I eventually got her in the computer.

Now she brings it to me and she cant type in the username and password, it's as if the keyboard is locked. the volume keys work, I can get into single user mode, I have also changed the RAM and reset the PRAM with no luck.

the keyboard does work in single user mode, I tried and I can type in single user mode. I just can't type in the username and password fields.

I don't know what to do here, I'm not very experienced with iMac or OS X.

any help will be greatly appreciated.

have you tried in single user mode the command fsck -y this runs basicly the disk utility repair.

just tried it came back with use fsck -f to force checking so I did that and it came back with the volume appears to be ok

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.