Hiya everyone,
I had an external 80gb Lacie firewire hard drive that worked on both my OS9 & OSX machines. Unfortunately the casing got damaged so it would not work via the firewire ports.
Most of the data on the drive relates to my old OS9 G4, so I am trying to install the drive as a secondry drive in the OS9 G4.
I have plugged it in and reconfigured the jumpers so that the original drive is the master and the new one is the slave.
The G4 boots up fine from the master drive but the slave drive doesnt show up.
I looked in the apple system profiler and the slave drive is there but is unmounted.
I then went into the drive setup application. The option to mount drive is greyed out on the slave drive. It only gives me the option to initialize the disk which I obviously dont wont to do cos I need the data of it.
Any ideas how to get this secondry drive to mount?
Many thanks,

Recommended Answers

All 5 Replies

May I be so bold as to ask why or how the casing on the external hard drive got damaged? Another thing, does the hard drive's partition(s) mount on OS X?

One of the firewire ports just stopped working a couple of years ago, think it burnt out. The second port got damaged by my little sister messing about with the cable. To the best of my knowledge the drive itself hasn't been knocked over or anything so I dont have any reason to think that the drive itself is damaged. A friend of mine has the same drive and he is coming over on Friday so we can put my drive in his casing just to double check that the drive itself does still work.

I cant test if the drive works in OSX as my OSX machine is a laptop and therefore I cant install it in there.

Any ideas???

Well, I would normally suggest something like Terminal, except that OS 9 doesn't have that capability... Definitely check the drive on another machine first, if you can get it on an OS X machine (even if the drive doesn't mount), try running some checks on the partitions with Disk Utility, which should confirm or deny the integrity of the drive.

I installed it in an OSX machine and it worked perfectly straight away, so thats a relief!
But, I need to be able to run it on my OS9 machine in order to salvage a lot of my work in my OS9s applications.
So now we know the drive works ok, any suggestions on why I cant mount it on OS9 when it always did before I took it out of its casing?

I'm not really sure. The only thing I can think of is backing up the drive, reformatting with Drive Setup, and then putting all the files back on it -- maybe not the most efficient solution, but I'm pretty sure it will work. Otherwise I'm out of ideas.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, learning, and sharing knowledge.