Hi everyone,

I recently purchased a 7 year old Powerbook G3 "Kanga" from someone on Ebay. I needed a laptop and was tired of dealing with all of the problems with Windows-based systems. I decided that this would be a great way to learn the Mac and save some $$$ at the same time. The computer came with a USB 2.0 CardBus PC Card (one of the reasons I went with this unit), it's in great physical shape and seems to work flawlessly, except for this one problem: I can't get it to recognize any of my USB devices. Not even one. I've installed the drivers that came with the devices, and still nothing. When I insert the USB card, a USB icon pops up onto the screen but when I plug anything into it nothing happens. I've checked the pins that the card plugs into, they're all fine. I can't find any software on the computer that has anything to do with the USB card itself, could this be the problem? I've already described everything that I know about the card, not even the name of the manufacturer is printed on it. Can anyone help me with this problem? Without USB, about the only thing this computer is good for is playing Civilization.

Recommended Answers

All 8 Replies

Update- I just plugged the USB card into one of our Dell work laptops and then plugged a USB mouse into it, the card's workin'. Help!


Tell us a bit more about the Mac Laptop. G3... it might already have USB on the back set of ports. I know my Lombardi already has it, and under OS 9, it will see the USB mouse and other things just fine.

You might also need to update to the latest (um, last) version of OS 9... 9.2 I think it was.

If you just purchased this laptop, I would also strongly suggest that you backup whatever is there, and rebuild the computer from scratch. That way, you know what is on there, how it is setup, and will learn the fundamentals of how the computer works. Being a beginner, do not expect this to go in 1/2 hour or so.

By doing this, you may eliminate other hidden surprises waiting for you. No one knows what the previous owner did to the machine, or what bugs might be there waiting. Format it and start it over. Clean slate.


It's a G3 "Kanga" and was manufactured in 1997. I believe it was the first G3 Powerbook ever made. It's running OS 9.1, and has a 250 Mhz processor. I've read that 9.1 is the newest version it will run. It doesn't have any USB ports on the back.

As far as the system rebuild, I'd love to do that, but I don't have any software. No CDs came with the computer. I know that I can download the OS from Apple, but I can't because I just discovered that the Ethernet card isn't working, either (we just got personal satellite internet service here in Afghanistan where I'm stationed). The only way would be to use one of our Dell work computers to download it, burn it on to a CD and then put it on my Mac after I've formatted the drive. But will that work? I guess it's worth a shot, something to do while I wait for my new Powerbook G4 to arrive. Thanks for your help.


Try reinstalling the USB Adapter Card extensions . Seems there is also an issue if processor cycling is on in the Energy Saver control panel on the G3's.

Hi Grant,
I've just joined this forum, and saw your problem with your Apple laptop. I have the same problem with an old powerpc 8600 that I recently acquired.
I fitted a Keyspan USB card, and everything looks great for abut ten minutes, then the computer freezes on me. I've upgraded from OS 9 to OS 9.1, which is the highest I can go. I've also downloaded the apple USB card support, but to no avail. I just wondered if you had solved your problem?



I never did fix the problem. I ended up buying a new Powerbook and it works great. I think the problem is that the OS hasn't been updated for so long that if just won't recognize any of the devices that I plug in. I tried an RCA MP3 player, several USB flash drives, and a digital camera. None of them would pop up onto the screen.

I ended up giving the USB card to a friend who had a Toshiba laptop with USB problems. It worked with his computer so I know it wasn't the card.

Sorry I'm of no help but since the new Powerbook arrived I haven't really messed with the old one. The old one has some math programs on it that I use for school, and that's about all I use it for now.

One more thing, it never froze on me. Maybe that will narrow it down some.

I suppose you've made sure your USB boxes are all checked on in the Extensions Manager?

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.