Somehow, I think my OS X is borked. Whenever you mouseover a menu, it's supposed to highlight, right? Well, mine doesn't... Also, my dock magnification is turned on, but if I highlight apps on my dock, they don't magnify, and it doesn't say the apps name above its icon. If I click on an app, the dock magnifies to it, but if I hover over another app the dock doesn't move (and is still magnified over the app I clicked on).

This stinks :-(. I don't even know what to search for, "mouseover not working?" Anyone know what's going on?


What version of OS X are you using? Under 10.3 (Panther), go into System Preferences and into the Dock control panel. Do you have magnificaton turned on? If you have the size of the icons LARGE, and Magnification to MAX, they won't get much larger.

Also, when it highlights over a menu, what menu do you refer to? A screenshot may be useful.



What version of OS X are you using? Under 10.3 (Panther), go into System Preferences and into the Dock control panel. Do you have magnificaton turned on? If you have the size of the icons LARGE, and Magnification to MAX, they won't get much larger.

Also, when it highlights over a menu, what menu do you refer to? A screenshot may be useful.


I am having exactly the same issue. I have a 24" iMac Intel with 10.4.8 and all current updates installed. The Dock is setup to Zoom b ut does not. On the top menu, I have two symptoms. 1) When I hover over ANY Menu item, it does not appear until I click on it. If I then move the Mouse over another Menu item, it does not appear. When I click on it, the menu appears momentarily, then disappears again until I click on it specifically. 2) Any Menu Item that is expandable (with a > arros next to it) does not expand when I hover over it. If I click on it, the entire menu disappears. This makes using ANY App near impossible. I entered a ticket with Apple support and they had me do the following in order:
A) Disk repair - did not fix the issue;
B) Archive and Install - did not fix the issue;
C) Install then import User Accounts and Applications from my full backup firewire drive. This also did not solve the issue, either before or after I ran Update (my disks are 10.4.7, the update is for 10.4.8). The problem presists in both my User account and my Admin account. I am not at home at the moment, but when I get home I will attach some screenshots.

Anyone have any ideas?


Hello. My system just started experiencing the same problems as you have outlined in this thread (magnification and mouseovers not working). Were you able to find any way to fix the problem. I can't seem to find any other references to this anywhere.


What fixed this problem (for me) was merely disconnecting the reciever of the mouse (a Logitech MX Laser <some-number>) and connecting it again. Oddly enough it wasn't sufficient to disconnect and reconnect the USB hub the reciever was connected to (as I initially tried out of pure laziness). I hope this is of assistance to someone :-)

Happy hacking :-)

For the sake of making it easier for others to find this thread via a search engine i'll add some keywords :
Mac OSX mouse hover problem
Mac OSX dock magnification not working
Mac OSX mouseover

Happy Hacking :-)

Thanks for that, unplugging my logitech laser mouse fixed the exact same issue I was having. Thought I was going mad when I couldn't find a preference to turn off this 'feature!'

sorry to post in an old thread.

i just had this problem as well.

if you find after disconnecting the receiver, it still doesn't work. try disconnect all USB devices and plug them back in.

this worked for me.

hopes this helps..

Wow, that was simple!

I too felt the same level of frustration in trying to describe the problem!



Years later and the problem still exists...I just spent a couple of hours trying to figure it out until I found this post...thanks!

So how did you solve it?

I unplugged mouse receiver from the USB port, then plugged it back in and all was good.

I hat the same mouse over issues. No menu except google chrome menus responded to mouse over actions.
I tried the trick to plug off and in the mouse but it helped just for seconds.

Then i switched the account and the mouse over worked! i switched back to my original user and there worked everything, too!

I just had this issue, nothing on here worked. But I finally got it working again by unplugging the mouse, shutting down, booting back up, logging back in then plugging the mouse back in; plugging the mouse back in before the other steps failed to yeild positive results.

I have a microsoft mouse and a targus mouse, both worked fine when the Anywhere MX wouldn't. Apple needs new drivers for this specific mouse.

And 3 months later, the issue persists. This problem only manifested itself when using the mousepad rather than the external Logitech wireless mouse connected via Bluetooth. Using the mouse again solved it, but I spent the better deal of half an hour working out what was wrong. Thought it was some sort of energy-saving "feature"...

I'm having this issue too (OS X 10.8.2, Saitek Cyborg R.A.T. 7 mouse). It's like the pointer is ignored. If you fire up games they behave in odd ways too - some don't respond to mouse movement, some do but erratically, some don't respond to clicks...

Not finding any of the above solutions help really. Is it possible that a different model of mouse would not have this problem?

I notice that when the mouse is plugged in, the trackpad also misbehaves in exactly the same way. Soon as I unplug the mouse, the trackpad works great.

Oh you guys rock! I just had the same problem, years after the original post here and unplugging the Logitech usb dongel fixed it. Very kool!!

YAY! Fixed. THANK YOU. Same issue, Logitech Performance MX mouse with Mac OSX, was not getting mouseovers in OS menus or online, mouse would also click very rapidly by itself and generate system error sound. This is a pity as the mouse was working just fine up until today, must have been some update that made it break. Using my magic mouse again for now with no issues. I was just about to wipe my computer and do a fresh install and migrate so THANK YOU for saving me the hasssle

my wireless mouse always have issues on Mac..i personally think its better to not use it..its more trouble than convenience actually

haha, so same problem. I was getting very upset. Unplugged the cord to the logitech blutooth receiver and then right back in, now it is working perfectly. I think it has something to do with when MAC updates the system, like now I am on Yosemite and I think that is when it started. So if your mouse is having hover problems, unplug it and plug it back in, (physically, not disconnecting and reconnecting using bluetooth). This resets the connection presets that the computer reads, now when you plug it back in, then it pulls the information again, fixing any changes that updating could have done.

If you experience such a issue, first be sure to check for hardware faults. Sometimes a mouse may be stuck because of a faulty connection, and if you have begun typing or playing a movie file then the cursor may become hidden by default

This post and thread should probably be closed.
Talking about a 10 year old mouse issue that doesn't say if it's wireless or wired. The posters that talk about wireless mice neglect to mention if theirs are optical or laser, which are fully different in action on my Macs. No known OS.
The two year old link, given by jfoo, in here is not working.
Just a suggestion.

I had same problem with Logitech MX Nano Wireless Mouse.. I tried change the usb port and it's working now. Not necessary to restart Mac. Thanks all.

It's great. All the info in one place.

12 years and the issue still persists!

I had the same issue after upgrading to MacOS Sierra. I'm using a Mad Catz R.A.T. 7, which is wired.

Unpluging and re-plugging all USB devices did not fix the issue.

Switching to another user account (and back again) fixed the mouse hover issue. Mouse hover now works for all users.

Not sure what happens when switching to another user account (and back again), but it has fixed the mouse hover issue. Something gets reset by performing this operation.

Suggest this thread be kept alive as it has been helping people for 12 years! : )

Can help this people even this year and beyond maybe.

Hey guys same problem here xD only the logout worked for me!
High Sierra
Logitech MX performance Darkfield, laser wireless

Same problem here.
macOS "High Sierra" 10.13.3
MacBook Pro (Retina, 15-inch, Mid 2015)

• Uninstall Cursorcerer
• Uninstall SteerMouse
• Remove wireless mouse USB-dongle
• Clear PRAM
• Multiple restarts

Upon restart (or new login) the hover starts working temporarily.

I now tried going to "Login Window..." via user menu.
That has helped so far.
EDIT: No longer working.

An ultra-f***ing-annoying problem, because not even the menus work properly.

If you find a solution, please post on this ancient — but nevertheless useful — thread.

I finally pinpointed the problem.
When ever I used a four-finger click custom event the OS simply stopped having any hover from cursor.
I remembered that I had updated it yesterday.

I apologize for wasting your attention.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.