I am a windows user. My husband has both a laptop and a desktop, both 10.3.8. The laptop has no problems. The desktop, after d/ling 10.3.8 update, told him he doesn't have permission/privilege/admin to do anything with HP Deskjet 940C printer. He has the most recent driver. Learned how to get in as root and found root is ok to print. My husband is the only user on the mac and is admin. He tried fixing permissions with tools and said permissions fixed - but no difference. He keeps getting messages saying the start up is almost full and he needs to remove stuff. He says there is almost nothing left in start up. He went back and re-downloaded update. Nothing makes a difference. I have no problem messing around in windows registry, but whatever mac calls their system stuff - neither of us is familiar. We need very detailed help - if anyone has any ideas ... Thanks

Have you tried removing and readding the printer from the list in the Print Center?

Have you tried removing and readding the printer from the list in the Print Center?

Yes, many times, we have added and removed the printer. We have deleted the printer .plist as well.

We have deleted the printer .plist as well.

Which one?

The printer information is stored in /Library/Preferences/.GlobalPreferences.plist, it is invisible in the Finder.

Please note, many (many many many) other things are stored here as well, so I don't lightly recommend removing the file.

Apple discussions told someone else who had problems to delete .plist and I am not sure but think it was .plistpreferences or some such similarly named and think it was in printer folder.

Starting from the HD and going thru folders and files... /Library/Preferences/.GlobalPreferences.plist does not exist on this mac
Is it invisible when looking this way?

BTW ... It is not JUST a printer problem here... also is OS X 10.3.8 administer , hp deskjet 940C, and startup disk issues ... dunno if they are all related or each problem by coincidence.

You should NOT (I repeat, NOT) operate the Mac OS when it's warning you that you're running out of disk space. You risk data corruption and the OS behaves very strangely. This could easily account for the problems you're having. Tell your husband to remove or back up unneeded data ASAP.

If that doesn't fix your problem:

Yes the file is invisible to the Finder, so you cannot see it that way. You need to use the terminal to remove/rename it.

Open /Applications/Utilites/Terminal, (I put this in code tags because it's a longish line) type:

sudo mv /Library/Preferences/.GlobalPreferences.plist /Library/Preferences/GlobalPreferences.plist.BAK

Now enter your admin password when prompted. This will rename the file. Now restart the computer and see if the print issue is fixed.

Problem was solved by rolling back to a previous version and archiving.

And this problem did not happen with Tiger.