When I was trying to return to 10.2.8 after working in 9.2 for a while- the computer froze up and nothing worked to unfreeze it. When I tried to reboot- I got the blinking question mark folder icon. I believe this means the computer cant find the operating system to boot up. So I tried booting from the Mac OS 10.2 install disk. --- it wont start up from the cd either!
I dont know what to do- since I cant even get it to boot from cd.

Since I'm a "starving artist" kinda guy, i cant really afford to take it to have a professional look at it. I'm hoping someone out there might have some good advice for me.


Have you tried holding down the Apple and X buttons when you power on? That is supposed to force it to load OS X.

Did you try to start from the CD with holding down the C-key while booting?

did you try to start the computer from the disc while holding the C key down? The computer may be trying to start form it's internal hard drive regardless of having a boot disc in the cd drive. I had similar trouble, but my hard drive was clicking prior to this. I was finally able to get the computer started with a cd but it didn't recognize my internal hard drive (the drive was dead). I had to replace the hard drive.
Hope this helps.

Have you tried holding down the Apple and X buttons when you power on? That is supposed to force it to load OS X.

Yes--- I have tried holding down the Apple and X- it didnt work.
I also tried holding down the C to start up from the Jaguar CD- no luck.
Also tried to start up from the OS X 10.1 CD that came with the computer- no luck. Also tried the Hardware Test CD- it wont start from any of these CDs.
After reading some posts on this site- I restarted holding down the Alt, Apple, R and P to reset the parameter ram. still no change.

When I restart holding down the Alt key to bring up the startup manager- it comes up- but offers no options to start up from- no os 9.2, no os 10.2.8, and no CD options are shown- just the Retry arrow and the startup arrow.

After reading stuff on Apple site- I tried starting up hoding down Alt, Apple, O and F- to start up in Open Firmware- then followed instructions to reset the "NVRAM" and "reset all"- this should allow me to restart from the CD- but it doesnt work.

So, I'm still stuck here with a dead iMac, hoping for a solution.
Thanks for trying to help!!!


I have an identical problem with my imac - I was wondering if you have found a fix for your problem yet? I had the drive clicking problem at first, then replaced the hard drive and while I can start to boot from a CD disc to install an OS ( I have tried 9. 10.2 and 10.3, it crashes during install like I have never seen.

There are no firmware updates for the flat panel imacs - mine is a 700Mhz model and I am feeling out in the cold on this!

Can anyone help me?

Hello thedawn,

Hmm. Your computer is down too. Not good. It sounds like you are in an install process, and the computer is crashing. That hints that the CD-ROM is being read, and that your hard drive is working, because it is writing at least some of the data.

I would boot with the CD's, and then before you start installing, go to the BlueApple (in the left corner), and run the disk utility. Delete and reformat your hard drive. Start it from scratch.

If that doesn't work, it might be bad media (bad cd-roms).

Let us know.


Hi Christian,

Thanks for your advice. Unfortunately I tried just about every erase option I could find including writing zeros to the entire drive.

The other thing which is wierd is that I can't eject the CD drive on startup. I have to go into open firmware (apple-option-o-f on startup) and type in ejectcd and then reboot. I don't think the CD's I'm using are bad as I have tried 3/4 different ones and they work fine on other computers.

I spoke to a apple technical colleague and when I told him I had changed the drive, he asked if it was Maxtor just as he has had a couple of problems with these drives in imacs! Anyway, thats my project for this week - find a different drive and try the same thing again.

Thanks again for your help and advice.



Have you found something besides a Maxtor? I have used them in Linux no problem. Also worked with Quantum and Western Digital.

Let us know.


When this happened to my, the Apple Store "Geek" told me that my logic board was fried because I had jumped from OS 9.2 to 10.3. He said that there were update directions in the 9.2.2 update that told the hardware how to run and because I didn't run the update, it basically fried. Now I have an Imac needing $500 surgery or I need to move my hard drive to a hard drive shell to access the data.

Good Luck!


I have a imac g4 that gets stuck on the white screen with the apple and the wheel. But it wont boot, it goes for about 45 secs then clicks off. I tried holding c or x but im using a wireless pc keyboard. Are there any alterante keys i can push that equilvant to apple keys

same problem as the rest wont boot to cd & no os on imac power-mac 4,the keyboard works at the white screen before boot.
are their any commands that you can use here other than continue or shut down?


do you have any other usb devices connected to the computer when you start up? If so - then try to reboot with only the keyboard and mouse connected.

What happens when you only have the mouse and keyboard connected (if you are doing that now... no worries. Just trying to figure out the order of things happening)? Same thing?

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.