0

Hey everyone, I'm having some trouble with windows vista, specifically with control panel and windows update. Basically, I've had a problem with windows update for awhile now; it just freezes every time I run it. I remedied that by scheduling auto updates, somehow if the computer initiates Windows update itself it does not freezes. Go figure. However I have a new problem tonight. I suddenly have a window popping up saying that my windows did not pass the genuine test. There was some tip on the Microsoft webpage but none of them worked.

Now when I try to open control panel, an empty window will pop up; then quickly closes itself. Also, windows update now will not open! Even though I see a update available icon at the task bar.


Here's my hijack this log:


Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 3:20:40 AM, on 7/26/2008
Platform: Windows Vista SP1 (WinNT 6.00.1905)
MSIE: Internet Explorer v7.00 (7.00.6001.18000)
Boot mode: Normal

Running processes:
C:\Windows\system32\taskeng.exe
C:\Windows\SYSTEM32\WISPTIS.EXE
C:\Windows\system32\Dwm.exe
C:\Windows\Explorer.EXE
C:\Windows\system32\WTablet\Wacom_TabletUser.exe
C:\Program Files\Synaptics\SynTP\SynTPEnh.exe
C:\Program Files\Java\jre1.6.0_07\bin\jusched.exe
C:\Windows\System32\TpShocks.exe
C:\Program Files\Zone Labs\ZoneAlarm\zlclient.exe
C:\Program Files\Analog Devices\Core\smax4pnp.exe
C:\Program Files\Synaptics\SynTP\SynTPLpr.exe
C:\Windows\System32\rundll32.exe
C:\Program Files\AVG\AVG8\avgtray.exe
C:\Windows\System32\rundll32.exe
C:\Program Files\Windows Media Player\wmpnscfg.exe
C:\Program Files\DAEMON Tools Lite\daemon.exe
C:\Program Files\Mozilla Sunbird\SunTray.exe
C:\Windows\system32\conime.exe
C:\Program Files\Mozilla Firefox\firefox.exe
C:\Windows\system32\wuauclt.exe
C:\Windows\system32\DllHost.exe
C:\Program Files\Notepad++\notepad++.exe
C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Bar = http://g.msn.com/0SEENUS/SAOS01?FORM=TOOLBR
R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://g.msn.com/0SEENUS/SAOS01?FORM=TOOLBR
R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://lenovo.live.com
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
R1 - HKCU\Software\Microsoft\Internet Explorer\SearchURL,(Default) = http://g.msn.com/0SEENUS/SAOS01?FORM=TOOLBR
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =
O1 - Hosts: ::1 localhost
O2 - BHO: Adobe PDF Reader Link Helper - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll
O2 - BHO: WormRadar.com IESiteBlocker.NavFilter - {3CA2F312-6F6E-4B53-A66E-4E65E497C8C0} - C:\Program Files\AVG\AVG8\avgssie.dll
O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O2 - BHO: Google Update Helper - {A4CC8907-3EA6-49EE-8B74-D09660120910} - C:\Program Files\Google\Update\1.2.121.9\GoopdateBho.dll
O2 - BHO: Google Toolbar Notifier BHO - {AF69DE43-7D58-4638-B6FA-CE66B5AD205D} - C:\Program Files\Google\GoogleToolbarNotifier\2.1.615.5858\swg.dll
O2 - BHO: Windows Live Toolbar Helper - {BDBD1DAD-C946-4A17-ADC1-64B5B4FF55D0} - C:\Program Files\Windows Live Toolbar\msntb.dll
O2 - BHO: Google Gears Helper - {E0FEFE40-FBF9-42AE-BA58-794CA7E3FB53} - C:\Program Files\Google\Google Gears\Internet Explorer\0.3.24.0\gears.dll
O2 - BHO: ThinkVantage Password Manager - {F040E541-A427-4CF7-85D8-75E3E0F476C5} - C:\Program Files\Lenovo\Client Security Solution\tvtpwm_ie_com.dll
O3 - Toolbar: Windows Live Toolbar - {BDAD1DAD-C946-4A17-ADC1-64B5B4FF55D0} - C:\Program Files\Windows Live Toolbar\msntb.dll
O4 - HKLM\..\Run: [SynTPEnh] C:\Program Files\Synaptics\SynTP\SynTPEnh.exe
O4 - HKLM\..\Run: [SunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_07\bin\jusched.exe"
O4 - HKLM\..\Run: [Windows Defender] %ProgramFiles%\Windows Defender\MSASCui.exe -hide
O4 - HKLM\..\Run: [Grid Service] "C:\Program Files\GridService\peer.exe" -n Grid
O4 - HKLM\..\Run: [TpShocks] TpShocks.exe
O4 - HKLM\..\Run: [ZoneAlarm Client] "C:\Program Files\Zone Labs\ZoneAlarm\zlclient.exe"
O4 - HKLM\..\Run: [SoundMAXPnP] C:\Program Files\Analog Devices\Core\smax4pnp.exe
O4 - HKLM\..\Run: [NvSvc] RUNDLL32.EXE C:\Windows\system32\nvsvc.dll,nvsvcStart
O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\Windows\system32\NvMcTray.dll,NvTaskbarInit
O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\Windows\system32\NvCpl.dll,NvStartup
O4 - HKLM\..\Run: [AVG8_TRAY] C:\PROGRA~1\AVG\AVG8\avgtray.exe
O4 - HKCU\..\Run: [WMPNSCFG] C:\Program Files\Windows Media Player\WMPNSCFG.exe
O4 - HKCU\..\Run: [DAEMON Tools Lite] "C:\Program Files\DAEMON Tools Lite\daemon.exe" -autorun
O4 - HKUS\S-1-5-19\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User '?')
O4 - HKUS\S-1-5-19\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter (User '?')
O4 - HKUS\S-1-5-20\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User '?')
O4 - HKUS\S-1-5-21-897023185-3356817522-3417811019-1005\..\Run: [WMPNSCFG] C:\Program Files\Windows Media Player\WMPNSCFG.exe (User '?')
O4 - S-1-5-21-897023185-3356817522-3417811019-1005 Startup: SunTray.exe - Shortcut.lnk = C:\Program Files\Mozilla Sunbird\SunTray.exe (User '?')
O4 - Startup: SunTray.exe - Shortcut.lnk = C:\Program Files\Mozilla Sunbird\SunTray.exe
O8 - Extra context menu item: &Windows Live Search - res://C:\Program Files\Windows Live Toolbar\msntb.dll/search.htm
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\Office12\EXCEL.EXE/3000
O9 - Extra button: (no name) - {0045D4BC-5189-4b67-969C-83BB1906C421} - C:\Program Files\Lenovo\Client Security Solution\tvtpwm_ie_com.dll
O9 - Extra 'Tools' menuitem: ThinkVantage Password Manager... - {0045D4BC-5189-4b67-969C-83BB1906C421} - C:\Program Files\Lenovo\Client Security Solution\tvtpwm_ie_com.dll
O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O9 - Extra button: (no name) - {09C04DA7-5B76-4EBC-BBEE-B25EAC5965F5} - C:\Program Files\Google\Google Gears\Internet Explorer\0.3.24.0\gears.dll
O9 - Extra 'Tools' menuitem: &Google Gears Settings - {09C04DA7-5B76-4EBC-BBEE-B25EAC5965F5} - C:\Program Files\Google\Google Gears\Internet Explorer\0.3.24.0\gears.dll
O13 - Gopher Prefix:
O18 - Protocol: linkscanner - {F274614C-63F8-47D5-A4D1-FBDDE494F8D1} - C:\Program Files\AVG\AVG8\avgpp.dll
O20 - AppInit_DLLs: avgrsstx.dll
O23 - Service: Ad-Aware 2007 Service (aawservice) - Lavasoft - C:\Program Files\Lavasoft\Ad-Aware 2007\aawservice.exe
O23 - Service: AVG8 E-mail Scanner (avg8emc) - AVG Technologies CZ, s.r.o. - C:\PROGRA~1\AVG\AVG8\avgemc.exe
O23 - Service: AVG8 WatchDog (avg8wd) - AVG Technologies CZ, s.r.o. - C:\PROGRA~1\AVG\AVG8\avgwdsvc.exe
O23 - Service: Google Update Service (gupdate1c8dbfc109e44a8) (gupdate1c8dbfc109e44a8) - Google Inc. - C:\Program Files\Google\Update\GoogleUpdate.exe
O23 - Service: lxcz_device - - C:\Windows\system32\lxczcoms.exe
O23 - Service: stllssvr - Unknown owner - C:\Program Files\Common Files\SureThing Shared\stllssvr.exe (file missing)
O23 - Service: TabletServiceWacom - Wacom Technology, Corp. - C:\Windows\system32\Wacom_Tablet.exe
O23 - Service: ThinkPad HDD APS Logging Service (TPHDEXLGSVC) - Lenovo. - C:\Windows\System32\TPHDEXLG.exe
O23 - Service: TVT Backup Protection Service - Unknown owner - C:\Program Files\Lenovo\Rescue and Recovery\rrpservice.exe
O23 - Service: TVT Backup Service - Lenovo Group Limited - C:\Program Files\Lenovo\Rescue and Recovery\rrservice.exe
O23 - Service: TrueVector Internet Monitor (vsmon) - Check Point Software Technologies LTD - C:\Windows\System32\ZoneLabs\vsmon.exe

--
End of file - 7840 bytes

My copy of Windows Vista came with the machine (A Thinkpad T61) so I'm pretty sure its genuine. I use AVG anti-virus and scans everyday.

I'm running an online Panda Virus Scan right now just to see if that sheds any light.

Please help!

5
Contributors
13
Replies
14
Views
9 Years
Discussion Span
Last Post by robertlose0912
0

If, when you click on Control Panel or System Restore or such, you get a blank white window, it could possibly be a script problem, and you may have to re-register some dll's. Try to re-register the following dll files in System32 folder. If you don't find the files, then try to extract then from your Vista setup DVD and copy them to System32 folder first.
vbscript.dll
jscript.dll
mshtml.dll

Emsa Register Dll Tool and Register/ Unregister OCX/DLL Utility
are two utilities, with which you can achieve the same on the fly.

Regarding the WU issue, check out if any of the troubleshooting steps given here help you.

0

Thanks for your help! I reregistered vbscript.dll and jscript.dll with no problem, but trying to reregister mshtml.dll gave this error message:

The module "mshtml.dll" was loaded but the entry-point DllRegisterServer was not found.

Make sure that "mshtml.dll" is a valid DLL or OCX file and then try again.


Reregistering the two file (vbscript.dll and jscript.dll) did not remedy my situation. (Should I restart after reregistering?)

Any ideas?

0

Did you buy your Thinkpad T61 secondhand?

Either way there is no guarantee that the OS is genuine.

The server at MS sees your windows vista version as non genuine and has put your OS into what Microsoft term as 'Reduced functionality mode' This is why the control panel and various other functions are not available.

Nothing you can really do here except to validate your version of windows with a genuine key.

Regards

0

I bought it from Lenovo first hand. The strange thing is, I've actually ran the genuine check before and passed, it was just yesterday I got a pop-up window saying "optional update failed" and that I need to run a genuine check.

Not sure where to go from here...

0

Here's what I got when I ran genuine validation:


This copy of Windows did not pass genuine validation.

Either an unauthorized change was made to your Windows license or a software program installed on this computer is not currently compatible with Windows Vista.


Recommended Solution

1. Restart the Software Licensing service.
* Click the Start button, click All Programs, click Accessories, right-click Command Prompt, and then choose Run as administrator. The Command Prompt window opens.
* In the Command Prompt window, type the command net start slsvc and then press ENTER.
* When the message "Software Licensing service was started" appears, close Command Prompt window.
* Validate your copy of Windows again by going to http://www.Microsoft.com/genuine and clicking Validate Windows.


When I try this, I got this message from cmd:

C:\Users\Matt>net start slsvc
The Software Licensing service is starting.
The Software Licensing service could not be started.

A system error has occurred.

System error 34 has occurred.

The wrong diskette is in the drive.
Insert *** (Volume Serial Number: ***) into drive ***.


I guess its great to know at least this is not a malware situation.

Any other ideas?

0

Here's what I got when I ran genuine validation:

This copy of Windows did not pass genuine validation.

Either an unauthorized change was made to your Windows license or a software program installed on this computer is not currently compatible with Windows Vista.

Your problems derive from one of these issues.....If you haven't installed any new software lately that may have contributed to the issue, then your best bet is to contact Microsoft and run through a phone validation procedure with them.

If your copy of windows is still deemed non-genuine by MS, you probably need to have an urgent talk with the supplier of your system and find out why this is so. It could just be an issues with the suppliers Vista Retail licensing conditions affecting their ability to issue genuine keys.

Good Luck

0

Thanks, I actually thing my Software Licensing service may be damage. As seen as my error messages:

C:\Users\Matt>net start slsvc
The Software Licensing service is starting.
The Software Licensing service could not be started.

A system error has occurred.

System error 34 has occurred.

The wrong diskette is in the drive.
Insert *** (Volume Serial Number: ***) into drive ***.


Any idea how to solve this?

0

If this doesnt work them im all out of ideas!

So you can check whether the Software Licensing service is running and start it if it’s not already running, and ensure the service is always started up in future, try the following:

Click Start and type Services or services.msc in the search box and then click on Services under Programs section of the search results on top pane.

If User Account Control ask your permission to continue, click Continue. If UAC asks for administrator’s password, enter a valid password.

Scroll down the list to the service Software Licensing and double-click it.
In the properties window of the Software Licensing service, set Startup type to Automatic.

Click Start to start the service. If the status is already running, click the Stop button and confirm with Yes to stop the service. Restart the service by clicking the Start button.

Click OK to exit from Software Licensing’s Properties window and close the Services window.

Go to www.microsoft.com/genuine and click the Validate Windows button to re-validate Windows. If you have problem with system updates, re-initiate system update.

The Software Licensing service can also be started with command prompt on high privilege elevation mode with the following command:

net start slsvc.exe


Good Luck!

0

So now I'm pretty sure my Software licensing service is damage; when attempting to start the service (It has been stopped, which I think is what my problem), I get an error message:

Windows could not start the software licensing service on local computer.

Error 0xd0000022:0xd0000022


Is there a way to repair that?

0

With Administrative rights go to C:\windows\, right click the system32 folder, select properties and clear the 'read only' chech box.
Click apply, then Ok!

By selecting the main System32 folder and making it read/write, Windows resets those folders back to their initial read/write status.

Then go through these steps again to try and initiate the SL service again:

Open a command prompt and run as administrator

Type: net start slsvc

If you do not have access to the Start button:

Click the option 'Access computer with reduced functionality' and a Browser should open, type: %windir%\system32 into the address field.

Find the file cmd.exe

Right Click on the cmd.exe and select Run as Administrator

Type: net start slsvc

You could also create a support request at http://go.microsoft.com/fwlink/?linkid=52029 for more assistance starting the Software Licensing Service......thats if you like dealing with tech support guys which is sorta like removing wisdom teeth with no anesthetic.

Regards

0

Had the exact same problem. I called Microsoft Vista SP1 support line 1-866-234-6020 , and they solved it for me.

At 8/8/08 3:00am, Vista initiate a windows update.

At 3:06am, Vista initiated a reboot

At 3:12am, Vista damaged its licensing token

Here’s the solution:


command prompt with admin rights:

Net stop slsvc (it was already stopped)

Cd\windows\serviceprofiles\networkservice\appdata\roaming\microsoft\softwarelicensing


Ren tokens.dat tokens.bad

Net start slsvc

Cd\windows\system32

SLMGR.vbs - rilc

Reboot

Enter vista product key and let it activate:


Reboot again

I'm completely disgusted with Vista / Mojave

0

I am happy to report that this solution, even after 2 years, still works beautifully. Iam surprised how vulnerable Vista is ... a botched Apple Safari install caused all this... Or simple uninstalling bloatware caused this. I found all this here: I followed this, but yours looks even simpler.

Edited by crunchie: Removed URL. Keep it on-the-site.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.