0

I have recently installed a new hard drive into my PC on which I installed Windows. I transferred all my stuff over to it, all goodies.

Now, I would like to format the "old" drive (C) and use drive D and E (E being a partition especially for Windows). The old hard drive (C) is IDE-1 and the new one is IDE-0.

I tried to set IDE-0 as the first boot device but when I do that, nothing happens, I just get the black screen and a tiny little line flashing in the upper left corner. I then have to restart and restore IDE-1 as the first boot device.

I was thinking of formatting C but if it won't start up after I've gotten rid of it, I can't really do it.

I think it's something to do with having E (Part of D) as a partition with Windows on it. I don't think it knows that it should look at E and not at D (Storage).

Other things I can tell you:

Info: http://img159.imageshack.us/img159/1949/infoxl3.jpg

HDs: http://img247.imageshack.us/img247/7178/hdsan9.jpg

Any advice would be greatly appreciated,

Cristalle

2
Contributors
21
Replies
22
Views
9 Years
Discussion Span
Last Post by gerbil
0

Hello, Cristalle. When you installed a second windows xp OS in the E: volume it did not alter your boot.ini file in C:\, did not install in the root of your new volume E: the files to load the OS. That is because it detected the old OS. If you check in your disk management console you will see that C: is the system drive [contains what some of us call the boot files in the root which load the system files which can be in another volume] and E: is your boot drive [which naturally is not the drive containing the files which "boot" the OS, but the files which are loaded by them... ie, your new OS].
Don't blame me, that is the way M$ uses those terms, boot and system.
And that is why Windows will not let you format C:, it knows it will not be able to start.
You marked D: as your Active partition - it contains the boot sector code which would normally load the files in its root which load Windows. But they are not there. And they cannot be in E: because it is a logical partition.
But no problem. We have to make D: your System partition.
Firstly, in an explorer window you must alter the Tools, Folder options, View settings to show Protected OS files [uncheck that option].
=Check in your E: drive for two files E:\ntldr, E:\ntdetect.com. Not there? Ok, just copy them over from C:\ to D:\. I repeat, to D:\
Next post here a copy of your boot.ini file. You can just drag it into an open notepad from C:\, else go Start, run, paste in..
control sysdm.cpl,,3 -Startup n Recovery settings, press Edit.
We will alter it to load your new OS directly from E:
Or... you can do this yourself:
Edit your boot.ini to look like this one:

[boot loader]
timeout=4
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

...note those two partition(2)....
-save it to D:\
Hide those OpSys files again.
Restart. Might work. :)
[Are they cats, or something?]

0

Thanks for your post! Maybe I read it wrong or ... I installed Windows on E, not on D. D is just storage and doesn't contain any Windows files. E is the one that has my Documents and Settings, Program Files and Windows. With that said, do I still have to move those files to D?

I kinda marked it Active because I thought it would make it start up~ I didn't really know what Active meant so... Hehe


P.S. Well Cookie is the cat, the other two are me and my boyfriend :]

0

Heya, Cristalle, yep, from your second pic I can see that Windows is installed on E: [the "boot" drive], which is a logical partition in an extended partition. Which is fine, but you can only mark a primary partition as Active, and you have done that- D: is Active. D: being the Active partition means it must also contain the boot or loader files [ntldr, ntdetect.com, boot.ini] because .... well, how much do you wish to know..?
Startup: ...this will be a very brief version of the chain of events!..... BIOS whirs, searches for the master boot record on the master disk [your Disk 00]. The MBR's partition table for the whole disk is read, logical partitions in an extended partition are successively investigated and the single, active partition is noted, the mbr code is loaded into memory, and BIOS hands control to that. The mbr code directs operations to the partition marked as active, specifically to its boot sector. All partitions contain the same boot sector code, but only that active partition's boot sector code is loaded; it assumes control and searches for certain files in the root of that partition. If your OS is XP then ntldr will be read into RAM and ntdetect.com will examine your hardware [and either BIOS or Windows will assign resources to them depending on whether you have ACPI].
ntldr will read boot.ini..... an on it goes.

You can check yourself that a logical drive cannot be Active - try to make it active with Disk Mgmt - the option just will not exist. You can see that C: is the System drive -that is where those 2 files plus boot.ini are right now, but BIOS cannot see them because it is not looking at that hard disk, and if it did then the partition is not active, so...
So, yep, copy those two files into D:\, make a boot.ini and copy that in also.
"Well Cookie is the cat, the other two are..." See? I know stuff.... :)

0

Woo! A lot of stuff! :]

Yeah I done it but I'm scared to restart my computer now~ hehe.

I followed it to the tee so it shouldn't be a problem.

Do I delete those files off of C now or do I just leave em there too? (Boot.ini, etc)

[Yeah you're clever, actually we're all supposed to be cats :P]

0

Ok so I got the courage to restart and nothing bad happened~ Phew!

So I guess it's all good now? Can I format C now? It's still calling it System and the other Active though which is a bit weird. What does that mean? Is it bad? No hope for me?! :( .

0

Oh~ It's still not letting me format. Looks like everything has reverted back to the way it was. But I did save the boot.ini to D so :-O

0

The way Windows Setup works can be quite confusing... was the old disk with C: on it still IDE-0 when you installed XP on the other disk?
And you changed the Active partition setting from C: to D: yourself? [if you had tried to restart after that you should have gotten a "ntldr is missing" message and a blue screen].
Anyway... it reverted? Right...
=temporarily edit the boot.ini file in D:\ to look like this:

[boot loader]
timeout=6
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows Prof D:" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows Professional" /noexecute=optin /fastdetect

-then during login you will be certain which boot.ini is being used- if it is this one then you will actually see the menu. The second line I added is a nonsense for your sys, something has to be there otherwise you will not see the menu; do NOT choose it, just let the menu timeout to default after 6 secs.
=Check, or set, D: to be Active, that ntldr and ntdetect.com [and boot.ini] are in D:\.
=Shut down and restart into BIOS, set to boot from cd and insert your XP cd, boot into the Recovery Console by typing R to Repair when given the choice during Setup. [If the sys manages to boot into Windows again accidentally then it may revert the settings above; redo them]
Let the loading of Recovery Console run to the point where it asks if you wish to start in E:\Windows, type 1 and Enter.
Now at the E:\WINDOWS prompt type..
fixboot D: -and Enter, and to the write query answer y and Enter again. Now type...
fixboot C: -Enter and answer y, Enter..... Type exit to quit, the sys should commence a restart.
=Restart into BIOS, set IDE-0 as boot device and let the system boot.
That should do the trick. Say what happens.... and if all is good edit boot.ini:

[boot loader]
timeout=6
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="MouMou's Windows Professional" /noexecute=optin /fastdetect

You can put whatever you like in there....
I for one don wanna be a cat... a couple of the things they do I find disturbing.

0

Hiya Gerbil,

C was always IDE-1 and now E is IDE-0.

"And you changed the Active partition setting from C: to D: yourself?"
I didn't switch it over, C was always (System) and when I right-clicked D I had the option to set it as (Active) so C never had (Active) next to it.

Also one thing about the booting thing, in the very early stages of boot I get the two options of "which ones of these do you want to start up, choose before the time runs out" or something of the sort and I have the first one and second one on the list which looks like that:

"Windows XP Professional"
"Windows XP Professional"

The first one is D/E, the newest XP.
The second one is C which I don't use anymore.

That's why I wanna format C, so then I won't have that option at boot up and it will just go directly into D/E.

I'll go try what you said now!


Yeah they are pretty disgusting in some stuff, but I never think of that ;)

0

I tried booting from CD but all I have on the boot list is:


Floppy: 1.4 MB 3 1/2

IDE-0 : ST3250823AS

IDE-1 : Maxtor 6E040L0

BBS-0 : Realtek RPL


And no CD! I haven't seen Realtek there before...

AAAAAH! What a pain, maybe I should just leave it alone? :'(

0

Heya, Cristalle.. when you install an new XP it pays not to let it see the old one... you should have removed the old disk first.
Then you would have got the OS installed in E: [M$ boot drive] and D: set as the M$ system drive with the loader files in it.
Ah...
"Windows XP Professional"
"Windows XP Professional" .. that would be the boot.ini file on C:.
"C was always (System)" .. that means it would have been Active also, but Active does not show if it is set on the System drive. There is only ever one Active partition if you are using Windows to set things.
Your cd must have been working a bit ago, try checking the cables which may have been dislodged when you inserted the new hd.... I do not know why you are seeing the BBS bootROM as a boot device, cos you have the IDE disks available, but ignore it.

In the first post to you I forgot to tell you to set IDE-0 as boot drive after copying in those files to D: and making the new boot.ini file for D:.
It should have gone in here:
...note those two partition(2)....
-save it to D:\
Hide those OpSys files again.
Restart. ** Set boot order to IDE-0 first.** Might work.

-doing that should be sufficient to get it to boot using D:, then you can delete those files from C:

0

I'll try setting the IDE now.

Well, I had to keep the old disk in there, otherwise I don't know how I would of transferred all my work and stuff from it.

I was advised things like: "You can't take it out or it won't start and it won't start up from CD either if you boot it fresh from there." Shouldn't of listened really. Gah! :@

Hope it works this time...

0

We have a big problem...

I'm currently on the other PC.

I restarted and then set boot from IDE-0 but still would just get that little line in the top left corner.

I then tried to start from IDE-1 and surprise surprise:

"Windows could not start because of a computer disk hardware configuration problem. Could not read from boot disk. Check boot path and disk hardware. Please check the Windows documentation about hardware disk configuration and your hardware reference manuals for additional information."

I shouldn't of medelled in it I think. I should of just left it like that because now I can't even do my work or anything. I don't know how to find the boot.ini now and the CD is being stupid...

I would just like it to go back to how it was and then I'm not touching it again. :(

0

Okay, that is one of the messages in ntldr, and because you reset the boot order to IDE-1 it is from the ntldr on C: drive; basically, it is saying that it is looking for XP but could not find or read the XP files on the E: drive. It managed earlier.
I have assumed a couple of things, and I should not have. Is your cd drive on the IDE-0 [primary] controller? That is fine, it should be the slave, the new hard drive the master. Is the old drive with C: master on the secondary controller? That is the configuration I wrote the boot.ini file for. But, please tell me the drives/controllers configuration that you have.
And did you get the cd drive working? Just wondering if the cabling connections are seated well because earlier the system booted just fine with IDE-1 as first boot device, and we have not altered anything on that.
To check could I have a copy of the boot.ini file on C: please, if you get the thing working? I do suspect connections are a problem atm.

0

Uhm I'm not sure if C is a master on the secondary controller, how would I find that out?

The thing with the CD drive is, that when the new HD was installed somehow the CD was not visible anymore. When you take out the new HD and connect everything back up, the CD comes back so probably something to do with cabling/connecting but seeing as I am not the one who delves into those things, I don't really have any power in it. My dad does it~ He does have some experience in it, but I don't think he fully understands this time because the CD drive should be fine too.

That's why I think I'll have to get that new HD out so then I will have the CD drive and C so that I can run the Recovery Console on it and get it up and running and then insert the new one again but without the CD.

I installed Windows through the other PC, I used the other PC's CD drive to do it, but now it doesn't see it anymore for some reason.

I can't really start it up either so I'll just have to wait till the new HD can be taken out. I will give you a copy once everything is back up again. But I don't know if I'll wanna change anything again coz I don't really want bad stuff to happen when I'm in the middle of a project and as I don't have a CD drive so I can recover Windows, it doesn't help either.

I'll keep you updated though when I get it back up and running :*

0

Hello, Cristalle... re the drive configuration - I am going to make a guess or two here.
Because you only had one hd and one cd drive before they were probably mounted on different IDE controllers and so both were set to Master? Then with the new hd installed the cd drive had to pair onto a controller with an hd and that may be the cause of a problem with BIOS and drive detection.
Now without knowing the make or type of your drives...
A. Put the hd's on the outer IDE cable connectors, one to each IDE controller.
B. Put the cd drive on the inner connector on IDE-1 [secondary controller] along with C: drive. That way the OS on E: gets a controller to itself and info transfer is more efficient. The OS does a lot of self checking, sys file reads while working and this setup means it won't get bogged down with file/music data transfers.
C1. If your sys and drives are reasonably new and if Cable Select CS is available simply set the jumpers on all drives to that; the system will sort out master and slave arrangements.
C2: Else if no CS, or simply if you wish, set the jumper on the hd on IDE-0 to Master [ Caution...if it is a Western Digital and is the ONLY unit on the controller then do not use a jumper], and....
On IDE-1 [secondary] set the hd jumper to Master, the cd unit to Slave.

Fold the cables neatly out of the air stream from the fans, try to avoid sharp bends.
Oughta work. With all drives in there at once.
"I installed Windows through the other PC, I used the other PC's CD drive to do it" -this is the new installation on E:? I am not sure I understand... When Setup runs it detects hardware configurations on the motherboard and selects from a choice of several HALs one to suit, copies it into your system32 and renames it to HAL.dll; different mobo configs, different HAls. When the system chooses drivers from a simply huge selection and you load chipset drivers from a cd they are set for that mobo, hardware. Diff sys, diff drivers is a good possibility... things may well work but not necessarily optimally. Upshot? Try to install on the sys that the OS will be running on.
How to hide an earlier Windows from Setup? Unplug the drive or simply rename the old X:\WINDOWS\ to X:\WONDERS\ or something. After you have done the first startup of the new installation you can revert the naming.
I know it is possible, you've done it, but with up to four primary, or three primary partitons plus an extended partition it is better to put an OS onto a primary.... less risk of introducing errors.
XP is better in a 8GB partition by itself. No apps and minimal data with it. But if your sys aint your life, that aint important. At all. :)

0

Just giving you an update:

Just got C working again by unplugging D/E and having the CD drive and installing/upgrading for it. Then, the new drive was inserted again (the CD not there). Even though D/E is plugged in, it won't detect it so now I'm left with C.

I'll try and do what you said with the connections and see how it goes but I still don't see why it shouldn't see D/E as they're plugged in there.

Fingers crossed. :S

0

Ok, fingers crossed here for you.
Seriously though, nothing we have done would damage a drive. If you set the jumpers according to its back panel diagram, as Master in the Primary and your sys does not any longer detect it, well, there are only two options.... first is back to the shop with it, second is flash BIOS with an upgrade if one is available.
But I'd be taking it back to the shop. Even new things break.
Is C: happy with the cd drive slaved with it?

0

Ok sooo!

The connections have been changed and everything, all combinations were tried to didn't work.

As soon as CD drive was unplugged, both drives were visible! >.<

Now, I can boot into C.

D + E are visible in My Computer and are accessible. WOOHOO!!!

Although I still get the:

"Windows XP Professional"
"Windows XP Professional"

...at start up, booting from the second one doesn't work and I get the error message "Windows could not start because of a computer disk hardware configuration problem...etc"

Could you tell me please what the default setting for the boot.ini is so I can paste it in there for D so I can boot from it.

Thankies! :)

0

Well, we've managed a few things...

Played around with it a bit and got things working so...

The CD player is now Master. On the same cable is the C drive (Slave) in slot 2.

SATA drive (D/E) is in slot 1 by itself.

Now I can see all of the drives and CD (Woo!) but I still can't boot into the D/E drive so we've gotta work something out with that.

So far so good ;)

0

D/E is a SATA drive? I presume you are using a Sata-IDE converter because you write of IDE-0? I spose I could have looked up the drive code in that boot list you gave in Post #11.... but I didn't.
Okay, glad you have it sorted electrically... does the cd drive insist upon being Master, otherwise it will not work? Or is it because you chose that config and did not alter the rear panel jumper?
Could you please give me a copy of the C:\boot.ini?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.