0

ive tried enabling telnet on windows 7 by doing the following:

1.Open control panel.
2.Then go into programs.
3.Then in programs and features there should be a part that says ‘turn windows features on or off ‘ .
4.Click ‘turn windows features on or off ‘ then on the list that appears simply check the box beside: Telnet Client.
5.Then click ok

But its still not working!! Getting the following error:
`telnet` is not recognised as an internal or external command, operable program or batch file.

Can someone help me out please??

8
Contributors
12
Replies
13
Views
7 Years
Discussion Span
Last Post by drew fullen
0

Which version of W7 are you using.
Also you may need to run as administrator to use Telnet
try right click on command prompt and run as administrator see if that works or enable the run command in your start menu and use run cmd

0

Which version of W7 are you using.
Also you may need to run as administrator to use Telnet
try right click on command prompt and run as administrator see if that works or enable the run command in your start menu and use run cmd

Hi Jem,

Its 64 bit windows 7 and i am logged in as administrator but its stilll not working??

0

Ok ghere are some alternatives.
first W7 does not give you full administrator rights even with an admin login. you have to use the right click and "run as administrator" option from an admin account to use telnet.
if this doesn't work use run as administrator command prompt and type this command: pkgmgr /iu:TelnetClient
if it still doesn't work try downloading a standalone telnet client like Putty.
Also I meant which edition are you using home, ult or business. as I seriously doubt this feature is available in Home basic.

0

Ok ghere are some alternatives.
first W7 does not give you full administrator rights even with an admin login. you have to use the right click and "run as administrator" option from an admin account to use telnet.
if this doesn't work use run as administrator command prompt and type this command: pkgmgr /iu:TelnetClient
if it still doesn't work try downloading a standalone telnet client like Putty.
Also I meant which edition are you using home, ult or business. as I seriously doubt this feature is available in Home basic.

Many thanks Jem, this is working fine now.. :)

0

Many thanks Jem, this is working fine now.. :)

Pardon my ignorance but what is this windows 7 telnet?
What is this for? I have Windows 7 ultimate OEM
Thanks for any explanation.

0

Pardon my ignorance but what is this windows 7 telnet?
What is this for? I have Windows 7 ultimate OEM
Thanks for any explanation.

Hi Pare,
Wikipedia has a fairly good explanation of telnet..See the link below

http://en.wikipedia.org/wiki/Telnet

0

Many thanks Jem, this is working fine now.. :)

If Jem solved your problem please don't leave your thread hanging.
please mark it solved Thank you. Later---

0

Its 64 bit windows 7 and i am logged in as administrator but its stilll not working??

0

it’s very rare that I use Telnet these days, so it took a long time for me to notice that by default it was not packaged with Windows 7. I did some research and found out that this was also true for Windows Vista. More than likely this was an attempt to make Windows more secure by default, as Telnet is very insecure and whenever you have the choice you should always use SSH. However, with that being said, you can quickly re-enable Telnet by following these steps:
1. Start
2. Control Panel
3. Programs And Features
4. Turn Windows features on or off
5. Check Telnet Client
6. Hit OK
After that you can start Telnet via Command Prompt

0

I had the same problem!
I followed the instructions above but its still not fully functional!
The problem is trying to connect to my Exchange 2003 server.
I've now supposidly got telnet, however, I try the following from a cmd prompt (run as administrator):
'telnet MyEmailServer 25'
This works fine on an XP machine, but I just can't connect with '7'.

0

Sussed it......
Damn McAfee got me again!
It got me with this about 5 years ago......
The mass mailing worm setting in McAfee was preventing me from contacting my mail server.
All sorted now.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.