0

I have a PDC Server running Windows Server 2003 that was on SP1. The server was low on disk space, but I was able to clear enough were SP2 indicated that it could be installed. Unfortunately half way through, it ran out of space and quit. When I tried to uninstall SP2 via Add/Remove the server crashed and now is not booting.

When I attempt boot it shows the Windows Server logo and progress bar for a few minutes and then BSODs with a Non-DLL error.

As this is my domain controller my whole network is out. Is there anything I can do to get into the system and back out of SP2? I'm in dire need of some help here ASAP.

If it matters it's running on a HP ML330 server

1
Contributor
1
Reply
3
Views
7 Years
Discussion Span
Last Post by Kurtismonger
0

In case anyone else has a similar problem, here is the solution:
Because this server had a RAID controller I first had to make a floppy disk with the driver. This was done using the HP SmartController CD. I then booted using the OS disk, pressed F6 to add third party drivers and did a install repair once the install program found the previous install of Windows Server. Initially I had trouble because Windows kept saying it had the proper RAID drivers, but I finally told it to use the one's I supplied and it worked.
After that it was just a matter of letting Windows go through the install/repair process. Amazingly after a few reboots 2003 booted fine and appears to have reverted to SP1 or at least replaced the SP2 files that were causing the problem. Active Directory and all other settings were still intact.

Edited by Kurtismonger: n/a

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.