0

Hey guys,

I have Windows XP Pro installed on a SATA drive and have now added a IDE drive containing Windows Server 2003 . Now the problem is, depending on the boot order of the disk drives, I can only load either XP or 2003. I do not get a multi-boot menu before loading to XP.

Here is how my boot.ini looked like:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

I looked around daniweb and found this thread and changed it accordingly although i was fairly certain it might not work because in that case, both the drives were IDE. This is what my boot.ini looks like now:

[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows Server 2003, Standard" /fastdetect

After this, when I select Windows 2003 Server in the boot options, the computer automatically restarts to the point of displaying the options again. Selecting XP boots fine to XP. Now how do i change my boot.ini file to accept the 2003 present on the IDE drive and give me the option to select an OS to boot?

Any kind of help would be welcome!

6
Contributors
8
Replies
9
Views
9 Years
Discussion Span
Last Post by Fazza
0

Hi daxie and welcome to DaniWeb

If you set boot order to boot from IDE first SATA drive should show as rdisk(1). Make sure you have your BIOS set to boot from the IDE drive then edit the boot.ini to

[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Standard" /fastdetect

How did that go?

0

Thanks, Mortal Terror, your idea worked! thanks a lot...........i changed the boot order to IDE and SATA and edited the 2003 Server boot.ini

One more question if you guys don't mind, i booted into 2003 fine. I have a USB keyboard/mouse. 2003 doesn't seem to detect them. Any other way than buying both of them in PS/2?

0

Is it only the keyboard and mouse 2003 doesn't detect or all usb devices?

Are they plugged directly into the usb port or via a usb hub?

0

They are plugged directly into the USB ports. Let me be a bit more clear on the 2003 installation. It was installed by somebody else for me to work on SAP, and so no drivers were installed. But I thought USB keyboard and mouse don't need drivers? I even checked the BIOS if there is any option somewhere to enable USB, couldn't find it. By the way, I use a 945GM motherboard.

0

After you enter the BIOS, look for the USB Legacy Support setting. Usually, this setting is found under the Advanced, Peripheral, or Peripheral Configuration menu, however your BIOS may be different.

0

They are plugged directly into the USB ports. Let me be a bit more clear on the 2003 installation. It was installed by somebody else for me to work on SAP, and so no drivers were installed. But I thought USB keyboard and mouse don't need drivers? I even checked the BIOS if there is any option somewhere to enable USB, couldn't find it. By the way, I use a 945GM motherboard.

never warry about that now , see here you will solve your problem smoothly , because there is one software named partition wizard , it can do many things without rebooting the windows , at the same time to keep your data and other important files , please come to this website :www.partitionwizard.com

0

Drivers for the keyboard and mice are built in to windows - what you most probably need is the chipset driver for your motherboard installing on the 2003 installation and then the USB ports will be properly detected/installed.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.