0

I have backup software, that was unable to solve the problem after trying to merge two partitions using EaseUS partition software. One would think with all the solutions online, after nearly three hours in total trying to fix the problem; I would have fixed it by now, unfortunately, no. From letting WinPE and my backup software try to fix the Boot Manager to the commands such as bootrec /fixmbr etc, nothing is working. I can't use my native Windows7 Professional disc because it is the upgrade disc and it is not compatible with my version of windows, that is the strict error it informs me about. The support from my backup software takes no responsibility and is blaming the issue on EaseUS which I was using a free verson, there is no support from them either. Windows obviously doesn't boot, I'm beginning to think it can't be fixed, despite the dozens of fixes online that don't relate to me.

3
Contributors
12
Replies
37
Views
3 Years
Discussion Span
Last Post by gerbil
0

You didn't perform a system image backup first, did you? This is the god of computing's lesson for you - NEVER mung with system disc formatting issues without doing a bit-image backup first to an external drive, so you can restore the system as it was if you or your tools mess it up...

My guess is that your system is FUBAR, and you will need to reinstall it. It may be possible to recover some of your data from the partitions with an external tool such as a Linux cd/dvd/usb drive, but that is not possible to say without physical access to your system.

0

I have a partition backup, I booted into WinPE and all my partitions, files are in tact, my assumption is the 100 meg boot partition that is set aside for booting is destroyed. Once again, all my files, partitions are in tact, I can see all the files, the only issue is getting Windows to boot once again.

Using the windows installation disc then running repair does not fix the problem, as so commonly recommended online.

0

Since nothing is working, quick question if I bought another HDD and threw it, what are my chances of getting fixed, perfect ? Everyone is telling me the same suggestions, the same recommendations and nothing is working, absolutely nothing has worked. I've tried the same suggestions more then twice.

0

Because you are using W7 you must use the program bcdedit.exe to repair your boot manager files. I have not ever had my hands on an upgrade disc, so I shall take your word for it that it cannot help. But you can download freely the w7 setup isos from Microsoft's download partner Digital River, and via the Repair option run bcdedit from there. Here on this site are the official links:
http://www.w7forums.com/threads/official-windows-7-sp1-iso-image-downloads.12325/page-2#post-124821
On the list down the page one of the top 6 should do (media refresh + SP1 isos)... just make suree to get 32 or 64 bit version as suits.
Instructions for bcdedit are here:
http://www.sevenforums.com/tutorials/2676-bcdedit-how-use.html
Or, use this simplified guide which perhaps better suits your situation:
https://neosmart.net/wiki/recovering-windows-bootloader/
That site gives a detailed instruction for repairing the booot manager (you still need that disc from DigitalRiver), as well as offering a 1-click cd for 20 bucks.
Come back if you need help with bcdedit... it IS logical, just a bit confusing at first, and everyone forgets how to use it cos they use it so rarely... :)

Edited by gerbil

0

And just for fun, if you are going to burn the iso to a UFD instead of a dvd (I use Rufus for this) you might wish to delete \sources\ei.cfg from the UFD - having done this, on any susbsequent running of Setup you will be presented with the option of selecting Home, Pro or Ultimate from the one iso. Choose to suit your activation key, of course...
To do it with a dvd burn you must first open the iso on your hdd, delete the file, rebuild the iso and then burn to dvd.

0

I burned the Windows 7 ISO to a USB Stick and it didn't work, yet I didn't know to delete ei.cfg. I'm going to try one more time, I've been nearly a week with the computer, I'll update come tomorrow night.

0

Hi. Deleting ei.cfg is only useful if you wish to use the same iso for installing different w7 flavours. Either way, it does not hurt. Leave it there...
Using Rufus....
-it will auto-detect your UFD
-select the MBR type
-FAT32 and default cluster size
-Quick format
-create bootable disc using ISO image!! Browse to your W7 iso.
It will take 10 - 15 mins to burn to stick.

0

The USB Boot Drive works, it boots into Windows where all my settings, programs are in perfect shape. Without the USB Windows Boot Drive, the computer doesn't boot into Windows, instead the error "BootMGR is Missing". I've read some online articles on how to fix when I'm in windows, so far all my attempts have failed. At preset Windows is working, only when booting from the USB Boot Drive, this is what I need to fix !

0

bootsect /nt60 sys -that should repair the system volume boot sector code. Operates in the same way as bootrec /fixboot

bootrec /fixmbr
bootrec /fixboot
You've tried these, and possibly this one also? Your system partition is Active, isn't it? That's the Sys Res 100MB partition where your boot files are written.
bootrec /rebuildbcd - here, were any installations found? If yes, you add it.
Time then, I think, to remove the old BCD store and replace it. Your problem might be that when you tried to merge partitions and it failed the bcd store was not updated with the correct boot partition sector offset (that is how windows finds partitions...). So bcd info is wrong, and perhaps the System reg hive info about partitions is wrong also (bootmgr checks that). So deleting the bcd file and rebuilding it might work, but bootmgr might find wrong info in the reg file. Oops.
Start with these commands, report back.

bcdedit /export c:\bcdSaved
del C:\boot\bcd
bootrec /rebuildbcd

Restart to see if that works. If not, then a pic of your partition layout would help. It may be time to replace your hive info with the backups.

Edited by gerbil

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.