I tried to restrict users from editing the local group policy in my computer just for security but not knowing... that doing that locally (computer not in a domain) will affect all the users who logs in in that certain PC even the Administrator account.
What I did is I open the MMC in the run command line, I add the Group Policy Snap-in and I remove the said snap-in in the policy so that others will not edit it.
I open it again the next day to edit the policies but I found that the said snap-in is missing, I run the gpedit.msc but a message window says that it was restricted by the administrator (having a code: CLSID:8FCOB734-AOE1-11D1-A7D3-0000F87571E3)...I tried

to run it in the Control Panel the same, it did't work..

Actually sir, my friend also accidentally disabled the Registry Editor and the MMC utility in his PC and everytime he run it for editing purposes, he got a error message..
Are there any solution to this!!!!!! Pls help!!
More power to us!!!!]

copy group policy from other same configue pc and paste in C:\WINDOWS\system32

Note: paste in safe mode only ,& group policy file is always a hidden file in system32

after u paste restart ur pc and than run>gpedit.msc>>intially 5 - 6 times u will get same error of snap shot than it will open..