0

I have a Toshiba Satellite P55W-C running 64-bit Windows 10 Home. I bought it new less than a year ago. I am the only user. It has an Intel Core i7 CPU, 8 Gigs of RAM, 2.4 GHz. I'm generally surfing the web and streaming audio/video. I'm not a gamer and I'm not running any servers on this computer, so it seems to me that I have more than enough resources to avoid any slow-down of the streaming video/audio. Normally it keeps up just fine, with the following exception.

I've been coding using Android Studio. When I compile/install apps to run on either the simulator or a real phone, Android Studio seems to hog all the resources and my web surfing/streaming can't keep up. It seems odd to me that Android Studio/phone simulators would need all the resources, but according to the Task Manager, it does. My question is why does Android Studio need that much CPU and/or memory and is there a way to keep it from hogging all of the CPU (i.e. is there an option in either Android Studio or Windows 10 to limit Android Studio to use only one processor or limit its share of the processing power and/or memory?)?

2
Contributors
6
Replies
19
Views
1 Year
Discussion Span
Last Post by AssertNull
0

Same here. The compiler does indeed max out on CPU and RAM. I think that's a good thing as we don't have to wait as long for a compile.

But more about the simulator. There are tomes on the web about using an x86 based Android in the Simulator along with notes from Intel about speeding up the emualator. If you are using an ARM based simulation that's more than double (some say 10x) the work.

0

OK, cool. Thank you. It's not the end of the world if it hogs all the resources. I just want to see if it will only hog MOST of them, so I'm going to spend a little time trying to see if there is a setting to make it only take 50% of the CPU or whatever just so the other programs don't stall. Hopefully I'll find a setting. If not, again, not the end of the world.

0

I think it's worth repeating that you need to change the emulator from an ARM to a x86 Android. I did that and it was a whole new ballgame.

Edited by rproffitt: Spelling.

0

I checked. Turns out I was using x86 anyway, though I hadn't paid attention when I picked the Simulator. I'll be sure not to use ARM. Now I DO have a choice between using x86 or x86 64-bit CPU. I'm using 64 bits since my computer/OS is 64 bits. I think my phone is actually 32 bits, but for the simulator I figured I might as well take advantage of my computer's resources, so I've been increasing RAM and Heap storage and basically just experimenting. Trial and error.

But for sure I'll pay extra attention to make sure I'm not using ARM for the CPU.

Thanks again.

1

OK, you've picked the x86 Android simulator so there are priors as to Android Studio using the CPU.
https://www.google.com/#q=limit+android+studio+cpu+usage

Hmm, now let me be sure my Java is current and I'll launch Android Studio and open a project.
http://i.imgur.com/NopLauD.png?1 is what happened and if you are seeing high CPU use with just the IDE and a project open, I think folk have priors on that. Here, I'm not seeing the issue.

Votes + Comments
Thanks for the links and the help!
0

I've been playing around with a few different options (RAM size, number of CPUs, etc.) and it seems to be doing better now. I can't remember the original settings that were making the system hang, but since it seems to be working better NOW, I won't try to recreate the settings that didn't work as well. All in all, marking this solved. Thank you for your help.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.