0

I just got my new laptop (after toasting my 2008 model with a glass of water on the keyboard). It's a Dell Inspiron 5748. I was excited to see it came with a USB 3.0 port (plus two USB 2.0 ports). The excitement vanished, however, when I tried my first copy. A ten gig file took 3 minutes to copy from an external USB 3 drive (a disappointing 60 MB/s more or less). Thinking there might be a problem with the drive I tried from another USB 3.0 drive as well as an external USB 3 SSD. Results were the same. The manual that comes with the laptop states:

USB 3.0 — This is also referred to as SuperSpeed USB. This port supports data transmission speed of up to 4.8 Gbps and is backward compatible with older USB standards.

USB 2.0 — Referred to as Hi-Speed USB, it provides additional bandwidth for multimedia and storage applications. USB 2.0 supports data transmission speed up to 480 Mbps.

I am getting neither high speed nor super speed.

It's especially galling in that when I try the drive in a USB 2.0 port I am told "this device would work much better if you plugged it into a USB 3 port. So obviously the system recognizes that the drive is capable of USB 3 speeds. My first go round with Dell resulted in being told that the actual speed is lower than stated because the data must be analyzed before copying and larger files take longer to analyze. As far as I know this is utter nonsense but when I asked to speak with someone who wasn't trying to jerk me around (not my exact words) I got put on endless hold (surprise). I'll try again after the Christmas rush.

Until then does anyone have any suggestions?

3
Contributors
10
Replies
22
Views
2 Years
Discussion Span
Last Post by gerbil
0

60MBps == 480mbps, more or less. Most hard drives cannot sustain more than that, interface speed notwithstanding. For small files, the speed may be greater, until the drive's write buffer is filled. Then it will fall back to the maximum throughput that the physical drive can handle. You may see better performance if you are writing to a USB 3.0 array where the output can be spread across multiple drives. Don't expect better for a single drive.

Edited by rubberman

0

But I still should see a major improvement when I use the USB 3 port, especially when I have an SSD attached. And how many laptop users are going to have a USB 3 array? That's kinda like a car manufacturer advertising that their cars get 400 mpg and then saying later that the number applies only if you are driving down a steep hill.

0

I'm a bit shy of bringing these points up to you, Jim...
1. Host controller driver is good?
2. USB 3.0 selected in BIOS?
3. Cable is blue USB 3.0?
Now don't flame me...

Edited by gerbil

0

Don't be shy. I'm not a hardware type of guy.

Host controller is good

Don't know. I'm assuming it is because it is a new laptop. Because of the poor speed I suppose that's a possibility. I've run the diagnostics and nothing pops up.

USB 3.0 selected in BIOS

I don't know if this is necessary but I'll check it. I can't imagine why it would be disabled (if that is even an option) by default.

Cable is blue USB 3.0

The cables are not blue, however they have the dimpled end that plug in oonly to USB 3.0 drives. The two external sealed unit drives I tried are USB 3.0 and the 2.5" exernal bay for 2.5" laptop drives is a NexStar 3.0 bay. The two regular hard drives I tried in that are less than 6 months old and the SSD that I tried was purchased last week (and worked just spiffing in my other laptop).

Edited by Reverend Jim

0

I want to relate a story from quite a few years back which may explain my mistrust of tech support, especially from the manufacturer. At the time I was working on a research project at the Shriner's Hospital. The terminal I used had twin cassette drives for data storage although nobody had yet actually used them. I was unable to get them to work so I called the manufacturer in Texas (I am in Winnipeg). They said the unit mught be faulty so I had the board shipped (insured) to Texas. After a few weeks it was returned with a note saying that it was working normally. I was still unable to get it to work according to the documentation and called Texas once again. I was told to ship it back down. More time and money wasted. When it returned it had the same note and I got the same results. After an angry call to Texas we shipped it down for the third time. Before it was returned I left for another research job at another hospital. I was told by the person who replaced me what the problem was. It seems that the repair person looked at the board and noticed that a chip was missing. He inserted the chip and found that the board was working properly. He concluded that there was nothing wrong with the board itself and then removed the chip before returning the board. He did this three times.

Un-freaking-believable.

So when I get doubletalk about "it's slower because of the analysis" it kind of makes my blood boil.

0

Hardware manufacturers and truth. From my experiences with USB 2.0 I can justifiably say that if a device is faster than USB 1.1 it will be called USB 2.0. I have a Sandisk Cruzer UFD, proudly claimed as USB2.0 - its write speed is just 35Mbps; read, i think, is about 80Mbps. Hardly 480. But more than 12.
So it may well be that if your USB 3.0 drive can clock reads at 490Mbps (and writes will be slower) they will claim it as the real deal. Time to check specs.
(I have lots of USB options in BIOS: on/off, family, speed...). But no 3.0... :(
Something else - dev mgr will tell you what family a particular USB device is using... at least with USB 2.0 it does. With 2.0 you will find the device located under Enhanced Controller if actually a 2.0, or Universal Controller (like my bluetooth keyboard/mouse) if 1.1. But I don't know about 3.0 stuff. Check under Devices by Connection, and expand entries.

Edited by gerbil

0

Under Universal Serial Bus controllers I have (for 3.0)

Intel(R) USB 3.0 eXtensible Host Controller
Intel(R) USB 3.0 Root Hub
0

Not got W7 open atm... XPing, as per usual, but I assume that you expanded USB 3.0 Extensible, and thence to USB 3.0 Root Hub. So if Root Hub is expandable you should eventually see your drive listed. If it's not expandable, then the Root Hub is not running any USB 3.0 devices. The hub may run ... I dunno.. 6 or 8 ports? You will only see the ones that have devices connected.
So if the device is not on a 3.0 Root Hub port, check inside the 2.0 Hubs under Enhanced Controllers. Test by plugging a UFD.
Note - this is all under View: Devices by Connection
BTW, all devices on a particular root hub share the bandwidth allocated to that hub..

Edited by gerbil

0

There is nothing expandable for USB in the view devices by connection. At the time I do the testing I have no other USB devices (other than my mouse) connected. Here is a screen snap

clip-0006.jpg

Disk 1 is the SSD drive in a USB 3.0 NexStar bay plugged into my USB 3.0 port. By the way, the spectaculart Dell Diagnostic tests only that the port can connect to a device. If it connects then it passes. No speed testing is done.

Edited by Reverend Jim

0

Jim, that's a Devices by Type view of DevMgr. Here is a view of my sys in Devices by Connection - you can see that rip-off Cruzer plugged into USB 2.0 (the Enhanced Controller). If I showed you a pic taken of SisoftSandra's display you would see all 6 ports of the Enhanced Controller's root hub with the UFD plugged into one of them.
Then, in the expanded Universal Controller you see my Logitech kbd n mouse running as USB 1.1.
Way it goes: each of the 2 Enhanced Controllers has 6 ports in their respective root hubs. For fallback to USB 1.1 there are 6 Universal Controllers, each with 2 ports in their root hubs. So 12 virtual ports of each type. Of the available 12 USB 2.0 ports in the two hubs I have only 8 physical ports.
The Enhanced Controller of a hub in use does the management - if a device is not capable of USB 2.0 it hands it off to another core in the chip, the Universal Controller.
Have a gander at the Devices by Connection view. DevMgr_by_Connie.JPG

Edited by gerbil

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.