0

I have Comcast cable Service a D-Link DI-624 Router abd A Lynksys Voip Router. I woke up yesterday and my PC, which has a wired connection to the D-Link router, and I cannot connect. The wireless connections are fine. My LAN status says connected, packets are Sent, but none recieved. I try to Repair and it fails, "Renewing your IP address cannot be completed." the LAN Status says I have an IP address and a Subnet Mask, but no Default Gateway.

I've tried to use the DOS Cmd to renew the IP Address and it fails. It says "An error occurred while renewing interface Local Area Connection: The requested service provider could not be loaded or initialized."

I did "ipconfig" and got:
Connection-Specific DNS Suffix : Blank
IP Address: 169.254.200.221
Subnet Mask: 255.255.0.0
Default Gateway: Blank

I've powered off the routers and modem. I've turned off and Firewalls. I'm running XP Home. This set up has been funtioning well for > two years. It won't access my routers by IP addresses.

I'm on my daughters MAC now, but I really need to get my PC back on line.

Thanks, Joe

2
Contributors
4
Replies
5
Views
9 Years
Discussion Span
Last Post by joepiccaso
0

Thanks, Jeff, but I've done all of that several times.

I just connected my PC directly to the modem. Powered eveything down. Uninstalled my network card in Device manager, ran network wizard. "Network did not assign a network address to the computer." and when I try to repair the connection it says "cannot renew IP Address."

All trouble shooting indicates all of my hardware is operating fine.

I looked into my "Event Viewer", now I'm really over my head, and I can see when the event occurred, but I don't know what happened. It's not the routers, I by-passed them. It's not the modem, my wireless works and my Voip works.

Did my Network card go bad, eventhough Device mgr says it's working fine and it reinstalls OK? Has my machine been highjacked by someone?

I appreciate your help!

Joe

0

I found a fix. I ran a Winsock fix and it repaired my Registry. I have a Registry cleaner that must have cleaned too well.

Thanks, Joe

0

make sure u r lan working r not?

Thanks, Kriss, I got it working with the Winsock fix. I deleted an Internet security program that must have attached itself to my registry and took out some needed files.

Everything is working well now.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.