Suddenly I have a VERY annoying problem with my dektop computer's wi-fi!
Very often, I just stop being able to visit websites or ping websites
(for example google.com).

When this happends, I am connected to my ISR, I can ping other computers in my network and my router but I can't visit any websites or ping them.

And before you ask, no it's not a DNS issue, and yes, I'm sure.


My laptop is also using wi-fi, and it has no issues what-so-ever!


Oh, also...
When I run a ipconfig /release, ipconfig /renew it seems to work for a short period of time.
Then the same thing happens...

What the hell could be causing this?

Try using an ethernet cable to connect instead or wireless for your dektop PC. Tell me whether it can still work, if both can't work it is computer related

Suddenly I have a VERY annoying problem with my dektop computer's wi-fi!
Very often, I just stop being able to visit websites or ping websites
(for example google.com).

When this happends, I am connected to my ISR, I can ping other computers in my network and my router but I can't visit any websites or ping them.

And before you ask, no it's not a DNS issue, and yes, I'm sure.


My laptop is also using wi-fi, and it has no issues what-so-ever!


Oh, also...
When I run a ipconfig /release, ipconfig /renew it seems to work for a short period of time.
Then the same thing happens...

What the hell could be causing this?

Are you using some network adapter for your desktop?
I'm sure you are, get that checked from a hardware friendly person.