I have created a small app in VB.Net,
Its was working well, I published it twice or thrice as well but now when I tried to publish it again
I got following error,
________________________________________________________________________________________

Error 3 An error occurred while signing: Failed to sign bin\Debug\app.publish\\setup.exe. SignTool Error: ISignedCode::Sign returned error: 0x80880253

The signer's certificate is not valid for signing.

SignTool Error: An error occurred while attempting to sign: bin\Debug\app.publish\\setup.exe Instant_Entry

________________________________________________________________________________________

I couldn't understand it,
and how to solve it :(

I had problems in the past publishing as well, just not sure if it was the same error, but it sounds like it was the same problem.

One solution I have found, was to use a 3rd party setup installer, like Inno Setup.
Then I would simply build the application, locate it in the bin/release folder, and add it along with the folders/files to the Inno Setup installer.

To fix the problem without using Inno Setup, I had to reinstall vb.net Express, which after a few more publishes, it would error once more.

Edited 6 Years Ago by codeorder: n/a

I found a temporary solution but I am not satisfied with this approach although, but still sharing this,

start a new project, and than all of your items in it one by one from your existing project,
the problem is solved, now you can publish it again,


but but but I want some else solution...

Hi,

I've never encountered this issue but it would seam to me to be to do with your projects signing settings. Right click on your project in the sooution explorer and you will get an option to open the project properties screen (alternatively Project Menu, Properties).

Depending on which version of visual studio your are using you may see something slightly different from me (I'm using 2008) There will be a Signing tab in the properties screen. Under the tab, I'm getting options to sign the assembly with a strong name and the click once deployments with a certificate. I'd suspect that this is checked and the certifcate you are using has expired you should be able to renew the certificate there or turn the option off.

As I said I haven't encountered this before but that's the best gues I can come up with.

Edited 6 Years Ago by G_Waddell: n/a

" Under the tab, I'm getting options to sign the assembly with a strong name and the click once deployments with a certificate. "

I reached to that Option
"Sign the Assembly"

I also checked it as well,

but I could not get the option
"once deployments with a certificate."

if it is not an option, then I could not under stand it :(

Hi
You've misunderstood me.

Try unchecking the Sign Assembley with a strong name option then Deploying.

There isn't any option about Click Once Deployment and certificates? because I thought this would be the one causing the issue. Either with no certificate selected or an out of date one.

As I said before I'm just guessing on this but maybe someone else who has encountered this error will have a better Idea.

What Version of Visual Studio are you using?

This article has been dead for over six months. Start a new discussion instead.