0

I have downloaded the J2SESDK and installed it. It is the bundle pack that comes with NetBeans. However when I run the installation only the directories for the 2 are created and there is nothing in there. I haven't a clue if thats supposed to happen but I'm guessing no. So when I tried the hello world test. I came up with this for the coding :

public class HellowWorld
{
    public static void main(string args[]);
    {
        System.out.println("Hello World");
    }
}

My error is a pathfile one.

Error : Invalid path, \bin\javac.exe -classpath "C:\Program Files\Xinox Software\JCreatorV3LE\MyProjects\New" -d C:\Program" Files\Xinox "Software\JCreatorV3LE\MyProjects\New C:\Program" Files\Xinox Software\JCreatorV3LE\MyProjects\New\HelloWorld.java 

I have no idea how to fix as there in no \bin directory in my JDK folder. In fact...like I said earlier, there is nothing. Like no installation took place. Any help?

Edited by mike_2000_17: Fixed formatting

2
Contributors
2
Replies
3
Views
10 Years
Discussion Span
Last Post by Lunaticrr
0

In most cases the bin lurks here:

C:\j2sdk1.4.2_04\bin

Just to check if things are working compile and run your program from here. If things are looking good then you can think about setting your paths correctly. There is a lot of info showing you how to set up your paths correctly- read it!

Btw java is case sensitive, so that typo - HellowWorld would cause some problems if you were compiling it from the command line like so:

javac HelloWorld.java

Try this even
http://www.personal.utulsa.edu/~jhl/csjava.htm

0

Thanks. I installed a earlier edition and it worked. All the files were there. Apparently something incompatible that made the installation not...install. Thanks for the help. :)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.