Visual Studio 2005 Professional Edition:
My app runs fine on my development computer, but, bombs out on the 3 other computers that I installed it on (all 3 were running Windows XP Pro). It installs OK, but, upon execution, it immediately aborts with a System.InvalidOperationException.

I inserted a MsgBox(" " command at the very beginning of the Form1_Load Subroutine, so I know that the program itself never executes.

The installs were all from CD.

Error signature

EventType: clr20r3 P1 : ortholabrx.exe P2 :1.0.0.0 P3: 447753H

P4 : ortholabrx P5:1.0.0.0 P6: 47753f1 P7 :1 f P8: c6

P9 : system.invalidoperationexception

========================================================

The following information about your process will be reported:

Exception Information

Code: Oxe0434f4d Flags: 0x00000001

Record: 0x0000000000000000 Address: Ox000000007c81eb33

System Information

Windows NT 5.I Build: 2600

CPU Vendor Code: 756E6547 - 49656E69 - 6C65746E

CPU Version: 00000681 CPU Feature Code: Q383F9FF

Module 1
OrthoLabRx.exe
Image Ease: 0x00400000 Image Size: 0x00000000
Checksum: 0x00000000 Time Stamp: Ox447753fl

Are you sure that Net Framework 2.0 is on the other computers? That is the only thing I can think of that could go wrong.

I suspect that this could be my problem:

My.Computer.Audio.Play("C:\Documents and Settings\Owner\My Documents\Visual Studio 2005\Projects\OrthoLabRx\OrthoLabRx\Resources\PodVwBy.wav")

I placed the .wav file in Resources, but, I can't seem to access it from there.
This does not work:
My.Computer.Audio.Play(My.Resources.PodVwBy)
It says "value of type 'System.IO.UnmangedMemoryStream' cannot be converted to 'String'.

That frequently went PFFFFFFFT instead of CLICK.

But, this did the trick!

My.Computer.Audio.Play(My.Resources.PodVwBy, AudioPlayMode.WaitToComplete)

I also have the same problem so can someone help???
The same error which is : event type clr20r3
P9 :system.inavalidoperationexception

Did you ever find the solution to the problem? I'm having the same problem and can't find a solution.

Thanks,
Dirk B.

I also have the same problem so can someone help???
The same error which is : event type clr20r3
P9 :system.inavalidoperationexception

Did you ever find a solution? If so, please pass it on because I'm in the same boat.

Thanks.

This article has been dead for over six months. Start a new discussion instead.