Im puzzled, the thing is, i have a software that was running ok, with a connection of to access 2010 db. A rotine to add a customer, to the database that was already coded, started to fail. saing that the insert method of the tableadapter was not avalaible. the tableadapter is ok, and it retrieves the data without any problems. WTF is going on. There is another tableadapter that works fine and the coding is the same.The strange thing is that the fill, getdata, etc is avalaible.

me.militarestableadapter.insert(idor,nom,mat)                            ^

          insert is not a member of dataset


Have you defined an Insert command for the Adaptor? Have you checked the syntax of the command by running it in your database?

Sorry i didn't understand, defined an insert command? what do you mean? I'Sorry but i'm new to these situations. The only thing that i did was changing the structure of the table?

Situation solved, thank for your help in showing the way g.wadell.
When i changed the structure of the table it created a second table called militares1, and for that reason the tableadapter did not know where to insert the data. I've delete the table from the datasource, and added again and the problem was solved.

Glad I could help - I think...