Ok. You need an Apache Module to do this.

Download it here- http://sourceforge.net/project/showfiles.php?group_id=175077&package_id=223778&release_id=490544


Since your Apache came from Wamp, the default installation path for the module will need to be changed to - C:\wamp\bin\apache\apache2.2.8 (or wherever your Apache is installed)

Next, you need to modify your httpd.conf file. To do so, Left Click once on your WampServer speedometer, goto Apache and there you can see the httpd.conf option. Add the following code

#asp.net
LoadModule aspdotnet_module "modules/mod_aspdotnet.so"

AddHandler asp.net asax ascx ashx asmx aspx axd config cs csproj licx rem resources resx soap vb 

vbproj vsdisco webinfo

<IfModule mod_aspdotnet.cpp> 
  # Mount the ASP.NET /asp application
  AspNetMount /SampleASP "C:/wamp/www/SampleASP"
  #/SampleASP is the alias name for asp.net to execute
  #"c:/SampleASP" is the actual execution of files/folders  in that location

  # Map all requests for /asp to the application files
  Alias /SampleASP "C:/wamp/www/SampleASP"
  #maps /SampleASP request to "c:/SampleASP"
  #now to get to the /SampleASP type [url]http://localhost/SampleASP[/url]
  #It'll redirect [url]http://localhost/SampleASP[/url] to "c:/SampleASP"

  # Allow asp.net scripts to be executed in the /SampleASP example
  <Directory "C:/wamp/www/SampleASP">
    Options FollowSymlinks ExecCGI
    Order allow,deny
    Allow from all
    DirectoryIndex index.htm index.aspx
   #default the index page to .htm and .aspx
  </Directory>

  # For all virtual ASP.NET webs, we need the aspnet_client files
  # to serve the client-side helper scripts.
  AliasMatch /aspnet_client/system_web/(\d+)_(\d+)_(\d+)_(\d+)/(.*) 

"C:/Windows/Microsoft.NET/Framework/v$1.$2.$3/ASP.NETClientFiles/$4"
  <Directory "C:/Windows/Microsoft.NET/Framework/v*/ASP.NETClientFiles">
    Options FollowSymlinks
    Order allow,deny
    Allow from all
  </Directory>
</IfModule>
#asp.net

Next, in your www folder, create a folder named SampleASP and put your aspx pages there. In case you need to change the folder, make the changes in the name in the code posted above.


When I did this I got the following error-

The current identity (NT AUTHORITY\SYSTEM) does not have write access to 'C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files'.

To correct this, create a folder "C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files" and set permission to write to it.

I am using Visual Studio 2008 Professional with Apache 2.2.8 on WampServer 2.0

This question has already been answered. Start a new discussion instead.