HI,

Well, I'm getting this error message when i try to open my project "Visual Studio cannot create or open the application because the web server on this computer is not running. Start the web server before preceeding".

I searched in google for any kind of help.. i found this website http://www.aspnetresources.com/blog/icq_damages_iis.aspx

I had google talk installed.. i uninstalled it. And ran those two commands.

But it didn't help me. Plz help me out. I'm stuck. I just hope i don't lose my project. Plzzzzzzzzz help me out.

you wont have lost your project it just cant open it as there doesnt seem to be a webserver on your pc. I have googletalk and it isnt interfering.

1. What version of visual studio are you using? 2005 or 2003?
2. What version of windows are you running?
3. Do you have IIS installed on your pc? (It isnt installed by default)
4. Has the project ever opened on this pc before and if so how long ago

Hi,

Version:Visual studio 2003
Windows XP
Yes, IIS is installed
I've run this project many times. Infact in the morning i had run my project.And again when i try to run it in the evening i get this error.

So have you checked to see if WWW publishing service is running on your pc? Is it somehow set to manual and stopped? Can you restart it? Then check the error logs and tell us what it says.

Something has stopped IIS so need to find out what it is. Then we can fix it

Yes, I tried... error..

Could not start the WWW Publishing service on Local Computer.
Error 1068: The dependancy service or group failed to start.

Can you check your application event log and your system event log to see if there are messages in there about the problem.

Hopefully they will shed some light

Yes, Application:

Errors at MSSQLSERVER,
Errors at MSiInstaller
Errors at Win Mgmt
Error at IOLO_SRV

System:

Errors at Service COntrol Manager
Error at DCOM

oh wow you have a lot there. something went majorly wrong somewhere.

You say that it worked this morning but not recently?

Did you install then uninstall googletalk this morning then it stopped working?

My advice it to use system restore to go back to either this morning when it worked or to a prior known good time.

You wont lose your project

I use MS SQLSERVER as the backend for my project... those errors .... are they the cause for the problem?

I had installed it almost a month back. And then yesterday had this problem.. and then i uninstalled it.

No luck, i had a restore point at yesterday evening 5:10. I restored. But didn't work.

Hi,

I can open my project now. I'm happy. I reinstalled (upgraded) windows xp. Now its opening... but i'm not able to run the project. Error:

"Unable to start debugging on the webserver. The server does not support debugging of ASP.NET or ATL Server applications. "

And thanks for all the help so far.

Ok :)
You may have to register asp.net with IIS again as you have done a resinstall. you want reg_iis.exe in the .netframework folder.(sorry i cant remember where exactly it is located) this should get it working

Hi,

Well, i ran that command.. and that error is solved.Thanks.. but.. another error...

The Web Server reported the following error when attempting to create or open the Web Project located at the following URL :"http://localhost/WebApplication2". 'HTTP/1.1 500 Internal Server Error'

Will these series of errors ever end???? Plz help me out. I'm tiered.

Ok. Because you reinstalled XP it is most likely the ASP.NET account or similar got messed up too.
The easiest (but time consuming) was to fix it will be to do a repair on Visual Studio (start the setup and choose the repair option - i think it is reinstall the same components or something).
That should reregister the ASP.NET account (Which i think is the problem) run IIS, register the isapi dll and a few other things to get everything back in sync.

You could try them all one at a time, but (i dont mean to sound negative) you are not familiar with the inner workings of windows and networks, accounts, IIS, com dlls etc and would be too risky to talk you through it. A reinstall will fix it.

This article has been dead for over six months. Start a new discussion instead.