0

My localhost is running on self-certified HTTPS and I am using Stripe API. I am getting following errors:

Warning: stream_socket_client() [function.stream-socket-client]: SSL: connection timeout in D:\xampp\htdocs\edplace_live\stripe\stripe\lib\Stripe\ApiRequestor.php on line 374

Warning: stream_socket_client() [function.stream-socket-client]: Failed to enable crypto in D:\xampp\htdocs\edplace_live\stripe\stripe\lib\Stripe\ApiRequestor.php on line 374

Warning: stream_socket_client() [function.stream-socket-client]: unable to connect to ssl://api.stripe.com:443 (Unknown error) in D:\xampp\htdocs\edplace_live\stripe\stripe\lib\Stripe\ApiRequestor.php on line 374

Warning: stream_context_get_params() expects parameter 1 to be resource, boolean given in D:\xampp\htdocs\edplace_live\stripe\stripe\lib\Stripe\ApiRequestor.php on line 385

Warning: openssl_x509_export() [function.openssl-x509-export]: cannot get cert from parameter 1 in D:\xampp\htdocs\edplace_live\stripe\stripe\lib\Stripe\ApiRequestor.php on line 389

Fatal error: Maximum execution time of 60 seconds exceeded in D:\xampp\htdocs\edplace_live\stripe\stripe\lib\Stripe\ApiRequestor.php on line 264

2
Contributors
1
Reply
6
Views
2 Years
Discussion Span
Last Post by Jack_11
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.