Alright, my situation is as stated:

After a create a asp webpage, (build it) i upload it to my ftp to get it online. But when I try to get to the url, it just displays the code as if it were a text file. When i press F5 and run it there, it works fine. Is there anything else i need to upload besides the content that it creates after i've built it so that it works right?

Any help on this would be appreciated.

-SiPex

The only thing i can think of is maybe the folder that you uploaded the application to may not be set as a Web Application, this would cause the aspx files to be displayed as plain text

I don't know your hosting so i don't know how you will test this

the files are coming up in the code view because you aren't hosting them under a web server, you have simply put them in an ftp site which merely acts more or less as a file server, you need to serve the pages within the context of a web server, e.g. point apache or IIS or some other web server to your directory and launch from there...

I'm uploading it to my godaddy hosting. Is that what's causing the problem?

Try this Assuming you are using .NET 2


Extract from http://help.godaddy.com/article.php?article_id=687&topic_id=216

To Enable ASP.NET 2.0 on Your Existing Hosting Account

  1. Log in to your Account Manager.
  2. In the My Products section, select Hosting Account List.
  3. Next to the hosting account you want to modify, click Open.
  4. In the Settings section of the Hosting Control Center, click the ASP.NET Runtime icon.
  5. Under the Hosting Directory section, select Content Root.
  6. In the Content Root Directory Settings section, select 2.0.
  7. Click Continue.
  8. Click Update.

i don't use godaddy so i'm not familiar with it, what web server do they use, i'm assuming they give you a windows based environment, in which case you're probably using IIS. set up a virtual directory in iis and run with it.

This article has been dead for over six months. Start a new discussion instead.