I wanted to install tomcat via YAST on a suse 10.2 system but the message says:

Package dependencies. Tomcat5-5.0.30-60.noarch[20071213-135049] cannot be installed due to missing dependencies. There are no installable providers of javamail >=1.3 for tomcat 5-5.0.30-60.noarch[20071213-135049]

What package(s) is needed first? Does anybody know? Thanks a lot.

Recommended Answers

All 5 Replies

You need javamail, version 1.3 or higher.

Search google.

Is it possible for you to try installing it from source? I did it on Centos 5.0.

I installed tomcat 6 from source. I first installed the JAVA environment. Then, tomcat.
If you are going to use apache with it with apache as a front end server, then you need to install the appropriate module so that apache connects with tomcat.


Installing what from source? javamail or Tomcat 6? Because I've had Tomcat 6 installed on my other machine for a little bit now, and I didn't have any compile errors.

I meant tomcat 6. However, before you install tomcat 6, you need to install the java environment, namely from the sun.com website.

Yeah, I have Tomcat 6 and the Java environment installed. Can't you install Java 6 from a package manager on your system?

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.