0

I am trying to install Microsoft Accounting 2008 Express, which requires installing SQL Server Express 2005. I have a Vista Home Premium machine and it's giving me fits trying to get SQL Server (any flavor) installed.

I've tried every tweak I can find online, but all to no avail. I've run the WMI Diagnositics Tool, but I have no idea how to read the output. The same goes for the install log in the Bootstrap Setup folder.

Has anyone on here been able to get this to work?

2
Contributors
33
Replies
34
Views
9 Years
Discussion Span
Last Post by dickersonka
0

Might want to try disabling UAC, disabling antivirus, and installing the most minimal set of options to start with. Also make sure you have vista sp1.

If all that fails, can you post some error messages or event log errors?

0

I've got the logs at home from the install attempt. I've already disabled UAC by default. No antivirus installed presently and I tried the option of disabling all non-Microsoft services, rebooted and tried again. The log files are huge - will they post here if they're large?

0

not for sure on the file size limits, if you could just post a few errors or last error encountered. Did you install vista sp1 yet?

0

Then if vs2008 is installed you already have sql express installed. I think the workstation components caused an issue.

Go into programs and features, select sql server 2005, and click uninstall then select workstation tools and complete that piece of the uninstall.

Then you should be able to run the install for sql server.

0

SQL Server 2005 Backward compatibility
SQL Server 2005 Books Online
SQL Server Compact 3.5 SP1
SQL Server Native Client
SQL Server Setup Support Files
SQL Server VSS Writer
SQL Server System CLR Tpes
SQLXML4

This is everything that says SQL in my programs.

0

It never hurts with Microsoft products to have fresh installs. Love their products, but sometimes they just don't play well together, or at least if not installed in some certain order.

0

Ok I removed VS 2005 and VS 2008 and all remnants of SQL server. I then rebooted and ran the install for VS 2008, making sure SQL Server 2005 Express was selected. Ran the install and the ending message was your program installed successfully...no errors. So just to be sure, I rebooted and then checked Services and installed programs and the only SQL installed is SQL VSS Writer????

So now, I want to install an express version of sql - so I'm going to download and attempt to install 2005. Will post back the results. This is just nuts!!! LOL

0

I got two warnings upon the initial install of express 2005: Edition Change Check (Warning)
Messages
Edition Change Check

To change an existing instance of Microsoft SQL Server 2005 to a different edition of SQL Server 2005, you must run SQL Server 2005 Setup from the command prompt and include the SKUUPGRADE=1 parameter.

and the other one was the asp.net error. I've been through IIS and configured all the non-default options required.

We'll see if this install goes through.

0

Still no go. I get the same error as I was before:

TITLE: Microsoft SQL Server 2005 Setup
------------------------------

SQL Server Setup Failed to compile the Managed Object Format (MOF) file C:\Program Files (x86)\Microsoft SQL Server\90\Shared\sqlmgmproviderxpsp2up.mof. To proceed, see "Troubleshooting an Installation of SQL Server 2005" or "How to: View SQL Server 2005 Setup Log Files" in SQL Server 2005 Setup Help documentation.

Now what?

0

C:\>winmgmt /verifyrepository
WMI repository is consistent

This is the response I get when I query the repository. I tried this before but tried it again this morning just in case it got jacked up in my uninstalling and reinstalling apps.

0

Ok - I had tried that last one, but misread it. So I just tried it again and got the same blasted error...ARGH. It should NOT be this difficult - LOL.

Any more suggestions?

0

Okay - maybe this is part of the problem??? Here's the response I get from running the command on the blog you just posted:

Microsoft (R) MOF Compiler Version 6.0.6000.16386
Copyright (c) Microsoft Corp. 1997-2006. All rights reserved.
File 'C:\Program Files\Microsoft SQL Server\90\Shared\sqlmgmproviderxpsp2up.mof' not found!

This is after I ran the regular 2005 Exp, got past the prerequisites installing, canceling and running the 2005 Exp SP2 that failed, which then uninstalls when I click on cancel.

Where does that file come from?

0

I can't figure out where that file is supposed to come from that isn't getting compiled. I don't know how it CAN get compiled when I can't find it anywhere...still looking...

0

I did run the mofcomp and when it didn't find that file, I did a search on my computer and didn't find it anywhere. Then I went to that folder Program Files/Microsoft SQL Server/90/Shared and there weren't many files in there at all. So I looked also at Program Files (x86)/Microsoft SQL Server/90/Shared and there weren't any files named that there either. I'm slightly stumped now because I don't know where or when that file is supposed to be there to compile...

0

Unfortunately starting to be at a loss as well. So you can't install sql express 2005 at all, or just can't get it working with the accounting?

0

I can't install it at all. When I try to install Accounting Express, that's the first thing it installs. When that fails, the whole install just stops. So that's when I tried to get it just installed by itself - that didn't work either.

I KNOW it will work on Home Premium, I just can't figure out why it's not installing on mine.

0

try
winmgmt /resetrepository

if that fails see if you can send me your bootstrap logs, i doubt you can post them, but you can send me a pm if it won't let you send them to me

0

Do I need to back out and uninstall everything that DID install (which doesn't included the database engine) before I run this command?

By the way - I really appreciate your help with this. I know it's been a royal pain!!

0

lol i don't have all the answers

first try it with whatever configuration you have right now

if that doesn't work, uninstall, run reset, run verify, then try the install

0

WMI repository reset failed
Error code: 0x8007041B
Facility: Win32
Description: A stop control has been sent to a service that other running services are dependent
on.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.