0

I'm trying to install Allegro for my Bloodshed compiler, but I seem to be having trouble adding the MINGDIR to my path. I've gotten to my environmental variables, clicked path and edit and added C:\Dev-Cpp\bin to the beginning of my path.

I've done 'gcc -v' in command line and gotten the appropriate blurb. I can get through the fix.bat mingw step with no problem. However, when I do the make command, I get "Your MINGDIR environmental variable is not set. I've looked at the ming32.txt doc, but I can't figure out what "then modify PATH and add MINGDIR" means.

I've tried adding c:\MINGW to my path and c:\MINGDIR to my path. I even added a variable named MINGDIR and set it to c:\MINGW, but that didn't work either. When I try to do make install I get error messages. When I try to run Allegro programs in Dev_C++, I getI've been at this for a few hours now and I'd really appreciate some help. <allegro.> no such file or directory.

I have already installed DirectX and added sdk...bin to binaries, lib to libraries, and include to both c include and c++include. I'm at my whit's end. Any help would be greatly appreciated.

2
Contributors
4
Replies
6
Views
10 Years
Discussion Span
Last Post by sciwizeh
0

in dev-cpp with your project open, go to Project->Project Options go to the parameters tab under linker type -lalleg hope this helps

0

in dev-cpp with your project open, go to Project->Project Options go to the parameters tab under linker type -lalleg hope this helps

No dice. When I try to compile a program, I get "main.cpp allegro.h: No such file or directory. " Any other suggestions?

0

does your plain "hello world" work in bloodshed?

#include <cstdlib>
#include <iostream>

using namespace std;

int main(int argc, char *argv[])
{
    system("PAUSE");
    return EXIT_SUCCESS;
}

you should see press any key... it should work

if that works i would try to reinstall allegro, from within bloodshed:
1) tools>check for updates/packages
2) from the first drop down select devpaks.org community devpaks
3) click check for updates
4) in the second drop down select allegro
5) select allegro
6) click download selected
7) follow the rest of the instructions onscreen

if this works you can do 1 of 2 things to use allegro, start a new windows application and do my
previous post, or, go to multimedia in a new project and select allegro application
if "hello world" doesn't work reinstall bloodshed Dev-C++

hope this helps

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.