0

Hi. I've had a website for five years that used to get lots of traffic from google and it was the first search result when i searched my name.

I recently installed wordpress to make it easier for me to update the site. Then I noticed I wasn't getting anymore traffic from google. So I typed both my name and separately the full url into google and in both cases google does not return even one result within my webpage!

It returns really random other websites that link to me, but not one directly to my website! I'm not very technically advanced - this is very frustrating for me because I don't understand what happened. Any advice would be much appreciated.

I am respecting the rule of not listing my specific url but if someone who wants to help needs it to see whats going on let me know.

thank you!
rebecca

6
Contributors
7
Replies
8
Views
9 Years
Discussion Span
Last Post by gdi
0

I recently installed wordpress to make it easier for me to update the site. Then I noticed I wasn't getting anymore traffic from google. So I typed both my name and separately the full url into google and in both cases google does not return even one result within my webpage!

What did you do with all of the pages when you switched to Wordpress?

Presumably the posts now have new URLs. Did you use a 301 redirect to tell Google where to go? It might have crawled your site, found a bunch of 404 errors, and then wiped your site from the index for some reason.

I'd also suggest signing up for Google Webmaster Tools so you can see errors that the crawler encounters. This would let you know if the problem is something crawl related.

If it's simply an SEO problem (although it sounds like you disappeared from the index altogether for some reason), you could try getting the All-in-One SEO plugin for Wordpress. Helps get the meta tags set up properly for SEO.

Good luck,
- Walkere

0

I will also suggest you to use Google Sitemap generator Plugin for Wordpress. That is a good one. Trust me wordpress is not only easy to manage your Pages but also SEO Friendly if you know how to customize it according to your need.

0

Just to contradict all the posters, if you have a problem with your site regardless of software the answer is rarely to install more plugins ;) KISS keep it simple stupid - might be an engineering principle but far to many web developers forget it.

A couple of things given how you described the problem I'm going to guess that the following happened:

You installed wordpress and got it working, you might have even setup permalinks to change ?id=12 to /02/02/2008/mytitle
You created pages for each of your content, you then deleted the original content.
I'm also going to assume you were ranking prior to installing Wordpress.

So starting back at the basics visit Google and put in the following:

site:yoursite

replace yoursite with well your site

Did it return results? if so something of your site is in the index, chance are Google has yet to index the new pages, proceed to install all the plugins you want. your rankings will return if you want to be adventurous try 301 the old pages to their new home. This will speed up the reranking process and help visitors following links to the old pages finding your content.

If it didn't return results then use the following again in Google

link:yoursite
Did it return results? If it did one of two possibilities is occurring 1) You have got yourself banned by Google and will need to apply for reinclusion this is very unlikely. 2) The much more likely reason you are somehow blocking or preventing spiders,

first check if your pages can be found if you visit yoursite does it return your wordpress blog if it doesn't do you have one or more links to the blog index page?

Second are you accidentally blocking it log into your admin page, then options, and privacy or simply jumpt to wp-admin/options-privacy.php
make sure the option "I would like my blog to be visible to everyone" is ticked and save.
If it was ticked go to the root of your site and look at robots.txt open it up
if it has a line that looks like:
User-agent: *
Disallow: /

The delete it.
Finally if you have found nothing to this point go to your blog home page and click view source in the header look at the meta tag:
<META NAME="ROBOTS" CONTENT="NOINDEX, NOFOLLOW">

If the link command didn't return any results and the site command did not return any results then you are not indexed and nor is any site that linked to you! given you use to be in the index this is unlikely so make sure you put in the right name site:www.mysite include .com or whatever the end is as well, don't include http and only include the www if your is accessed via www.mysite. If however you still get no results then do the checks detailed for result on the links and then go find some links from sites you know rank to help Google refind your site, you might also want to write a post on your blog to allow it to ping the various services which will in turn notify Google.

If none of this worked for you :) then you might need to let someone know the URL to have a look.

0

thanks tnash,
wow, i just checked in the privacy settings and the block search engines was checked! i just changed it and am going to double check the robots.txt and other stuff, but hopefully this will change things. I can't believe that was checked, did I check it? No memory, but we'll see what happens...

0

I'm glad the problem was solved, sometimes it can be easy to over miss things, you might want to use a service like ping-o-matic to manually ping sites before your next post and then continue to do so once a day for about a week, it will help bring bots back to find your old content which they have not had access to in, rather then waiting for Google to come along on its own or when Google Blog search is pinged from a new post.

0

The search engines are very sensitive when it comes to new content. A few minor changes can change everything as far as rankings go.. which kinda sucks.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.