0

Halo Guys

I was working on a website making changes for my client when i finished and refreshed the website gave me this message

There has been an error processing your request
Exception printing is disabled by default for security reasons.
Error log record number `********`

i followed instructions on how to make the error visible then i got this:

SQLSTATE[HY000] [2005] Unknown MySQL server host 'db795.1und1.de' (1)

Trace:
#0 /home/.sites/62/site1586/web/lib/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /home/.sites/62/site1586/web/lib/Varien/Db/Adapter/Pdo/Mysql.php(251): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /home/.sites/62/site1586/web/lib/Zend/Db/Adapter/Abstract.php(448): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 /home/.sites/62/site1586/web/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
#4 /home/.sites/62/site1586/web/lib/Varien/Db/Adapter/Pdo/Mysql.php(333): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
#5 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/Resource/Type/Db/Pdo/Mysql.php(45): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
#6 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/Resource.php(93): Mage_Core_Model_Resource_Type_Db_Pdo_Mysql->getConnection(Object(Mage_Core_Model_Config_Element))
#7 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(297): Mage_Core_Model_Resource->getConnection('core_read')
#8 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(312): Mage_Core_Model_Mysql4_Abstract->_getConnection('read')
#9 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(332): Mage_Core_Model_Mysql4_Abstract->_getReadAdapter()
#10 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/Mysql4/Collection/Abstract.php(97): Mage_Core_Model_Mysql4_Abstract->getReadConnection()
#11 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/Config.php(1206): Mage_Core_Model_Mysql4_Collection_Abstract->__construct(Object(Mage_Core_Model_Mysql4_Website))
#12 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/Config.php(1239): Mage_Core_Model_Config->getModelInstance('core_mysql4/web...', Object(Mage_Core_Model_Mysql4_Website))
#13 /home/.sites/62/site1586/web/app/Mage.php(460): Mage_Core_Model_Config->getResourceModelInstance('core/website_co...', Object(Mage_Core_Model_Mysql4_Website))
#14 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/Abstract.php(208): Mage::getResourceModel('core/website_co...', Object(Mage_Core_Model_Mysql4_Website))
#15 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/Abstract.php(213): Mage_Core_Model_Abstract->getResourceCollection()
#16 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/App.php(532): Mage_Core_Model_Abstract->getCollection()
#17 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/App.php(393): Mage_Core_Model_App->_initStores()
#18 /home/.sites/62/site1586/web/app/code/core/Mage/Core/Model/App.php(299): Mage_Core_Model_App->_initCurrentStore('', 'store')
#19 /home/.sites/62/site1586/web/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#20 /home/.sites/62/site1586/web/index.php(80): Mage::run('', 'store')
#21 {main}

does any one know who to fix this or is it a problem with my hosting company

thank you

2
Contributors
1
Reply
5
Views
6 Years
Discussion Span
Last Post by LastMitch
0

This error it usually means you are not connected to your database:

SQLSTATE[HY000] [2005] Unknown MySQL server host 'db795.1und1.de' (1)

It also means those certain files are not connected correctly.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.