0

Hi There,

I am quite new for web development. I am building a personal website and using Dreamweaver CS3. I am using a table layout which looks very fine in firefox (version 3.0.8), but it looks awful in Internet Explorer. (IE 7.0). Its really frustrating. I am attaching a word document which has screen shots of both versions. If any body could hel, I will really appreciate that.

Thanks,
Sri

3
Contributors
3
Replies
4
Views
8 Years
Discussion Span
Last Post by MidiMagic
0

Hi Sri,
you can post the part of the html code that's concerning the issue so we can figure it out. there's a lot of compatibility issues in this part.

Regards,
AHMD H

0

Here is the whole code for that page I am building. I am using the table layout. (merging splitting cells etc)

Thanks. AHMD.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Untitled Document</title>
<script src="Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
<link href="p7ssm/p7ssm_01.css" rel="stylesheet" type="text/css" media="all" />
<script type="text/javascript" src="p7ssm/p7SSMscripts.js"></script>
</head>

<body bgcolor="#000000">
<p>&nbsp;</p>
<table width="781" height="565" border="1" align="center">
  <tr>
    <td height="32" colspan="2" bgcolor="#333333">&nbsp;</td>
  </tr>
  <tr>
    <td width="121" rowspan="2">&nbsp;</td>
    <td height="89">&nbsp;</td>
  </tr>
  <tr>
    <td height="23"><script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0','width','100','height','22','title','HomeButton','src','Home','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','bgcolor','#000000','movie','Home' ); //end AC code
</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" width="100" height="22" title="HomeButton">
      <param name="movie" value="Home.swf" />
      <param name="quality" value="high" />
      <param name="bgcolor" value="#000000" />
      <embed src="Home.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="100" height="22" bgcolor="#000000"></embed>
    </object></noscript>
  <script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0','width','100','height','22','title','AboutButton','src','About','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','bgcolor','#000000','movie','About' ); //end AC code
</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" width="100" height="22" title="AboutButton">
    <param name="movie" value="About.swf" />
    <param name="quality" value="high" />
    <param name="bgcolor" value="#000000" />
    <embed src="About.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="100" height="22" bgcolor="#000000"></embed>
  </object></noscript>
<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0','width','100','height','22','title','PortfolioButton','src','Portfolio','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','bgcolor','#000000','movie','Portfolio' ); //end AC code
</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" width="100" height="22" title="PortfolioButton">
  <param name="movie" value="Portfolio.swf" />
  <param name="quality" value="high" />
  <param name="bgcolor" value="#000000" />
  <embed src="Portfolio.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="100" height="22" bgcolor="#000000"></embed>
</object></noscript>
<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0','width','100','height','22','title','ContactButton','src','Contact','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','bgcolor','#000000','movie','Contact' ); //end AC code
</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" width="100" height="22" title="ContactButton">
  <param name="movie" value="Contact.swf" />
  <param name="quality" value="high" />
  <param name="bgcolor" value="#000000" />
  <embed src="Contact.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="100" height="22" bgcolor="#000000"></embed>
</object></noscript></td>
  </tr>
  <tr>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
  </tr>
  
  <tr>
    <td height="29" colspan="2" bgcolor="#333333">&nbsp;</td>
  </tr>
</table>
</body>
</html>
0

One problem is that you are using outdated code. It throws the browsers into "quirks" mode.

the embed tag is deprecated (embed never was a valid tag - it worked on Mozilla browsers, but nothing else).

The following are NOT allowed inside xhtml tags. They are deprecated in xhtml strict:

bgcolor=
width=
height=
name=

Nonzero numbers used for measurement are not allowed without units of measure (your width and height values should be 100px, not just 100).

Zero values must never have units of measure. &nbsp; is not the proper way to hold a blank table cell. You should use the <br /> tag instead.

Note that only one of your scripts will be run by certain browsers. Normally scripts should be placed in external files. The browser normally runs only one script at rendering time, and others as called by button codes. So there should be only one script tag if you expect the script to run at rendering time.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.