0

I've created an HTML email which has a link back to my website. It works fine in every mail client that I've tested except Yahoo mail. Yahoo mail adds rel="nofollow" and deletes the href link.

For examplE:

<a style="text-decoration:none;font-size:16px;color:#0000CC;" href="www.xyz.com" target="_blank">Visit Us</a>

is replaced with

<a rel="nofollow" style="text-decoration:none;font-size:16px;color:#0000CC;">Visit Us</a>

Consequently, there's no link in Yahoo mail.

I have not been to find any documentation on how to prevent this from happening. Any inputs would be appreciated.

Thanks.
David

8
Contributors
9
Replies
32
Views
6 Years
Discussion Span
Last Post by Orane_1
0

Hi David

Yahoo mail client is known for adding the "nofollow" to all incoming links from anyone. If you create an email in yahoo mail client with a link in it, it will also ad the "nofollow" to the link. Yahoo is doing this automatically, and I think the reasoning behind this may be to help combat spam links to count in search engines.

0

The problem is that the link, ie href="www.xyz.com", is removed by Yahoo and consequently the link is unavailable to the recipient. Clearly there is something that Yahoo is looking for because it doesn't always remove the link and I need to know how to prevent Yahoo from removing it.

Any ideas?

Thanks

0

There are two possibilities. Firstly, it can be a setting on the receiver of the email that is set to something like "do not display active links" or "images" or yahoo may think it is junk mail or spam mail and filtered it not to show links or images.

0

I'm having the same problem. It's not a user setting, or even because the message is getting caught in the SPAM folder... it's something else. Unfortunately though, I'm stuck on this. Anyone know the answer?

0

Thanks to all for sharing this useful information.I have never tried it before but now i will try to do it.

0

The problem is that the value of the href attribute in your link is missing the "http://" protocol-prefix.

So instead of href="www.xyz.com" it should be href="http://www.xyz.com" (or a different prefix like "https://" or "ftp://", etc.)

Yahoo still shouldn't be doing what they're doing (ie. changing the content of an email with absolutely no warning to the user), but at least it's something you can easily fix. :)

0

2 years later, yahoo make an even dumber decission and even if the href has the https protocol it will add the nofollow rel on the <a></a> tags...

Any way to bypass this now??

0

Hi guys, to conform to the current Yahoo mail standards, ensure you have the target="_blank" to your anchor tags along with absolute URLS with http or https.
Also, I noticed that using tables to display your data is better handled in Yahoo Mail.
Don't worry too much about the rel="nofollow", that shouldn't cause any issues to the recipient.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.